POJ 3070 Fibonacci(矩阵快速幂)

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12271 Accepted: 8707
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
const int mod=10000;
typedef long long int LL;
LL n;
struct Node
{
    int a[3][3];
};
Node multiply(Node a,Node b)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                (c.a[i][k]+=(a.a[i][j]*b.a[j][k])%mod)%=mod;
            }
        }
    }
    return c;
}
Node get(Node a,LL x)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0;i<2;i++)
        c.a[i][i]=1;
    for(x;x;x>>=1)
    {
        if(x&1) c=multiply(c,a);
        a=multiply(a,a);
    }
    return c;
}
int main()
{
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==-1)
            break;
        if(n==0)
        {
            printf("0\n");
            continue;
        }
         Node a;
         a.a[0][0]=1;a.a[0][1]=1;
         a.a[1][0]=1;a.a[1][1]=0;
         a=get(a,n);
         printf("%d\n",a.a[0][1]);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值