POJ 1251 Jungle Roads(最小生成树)

Jungle Roads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23272 Accepted: 10864

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题目链接:http://poj.org/problem?id=1251


【分析】

            典型的最小生成树问题,就是输入一个N表示N个城市,下面N-1行第一个字        符表示城市,接着是一个数字表示有几个城市与之相连,接着就是字符和数字的        组合,表示城市与每行第一个字符表示的城市之间的距离。


【代码】

Prim算法

<span style="font-size:18px;">/*
prim
Memory 168K
Time    0MS
*/
#include <iostream>
using namespace std;
#define MAXV 30
#define inf 1<<29

int map[MAXV][MAXV],n,d[MAXV],vis[MAXV];

void prim()
{
	int i,j,mi,v;
	for(i=0;i<n;i++)
    {
		d[i]=map[0][i];
		vis[i]=0;
	}
	for(i=1;i<=n;i++)
	{
		mi=inf;
		for(j=0;j<n;j++)
		{
			if(!vis[j] && mi>d[j])
			{
				v=j;
				mi=d[j];
			}
		}
		vis[v]=1;
		for(j=0;j<n;j++)
			if(!vis[j] && d[j]>map[v][j])		/* 和dijstra不同的一点是这里找的是最小邻边 */
				d[j]=map[v][j];                 /* dijstra(单源最短路)中d[j]保存的是j点到起点的距离,而现在保存的是j点到邻点的距离 */
	}
	for(i=1;i<n;i++)
        d[0]+=d[i];     // 题目要求走完所以城市的路径最短,单源最短路是走到某个城市的最短路
	printf("%d\n",d[0]);
}

int main()
{
	int i,j,m,c;
	char a[2],b[2];
	while(scanf("%d",&n) && n)
    {
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=inf;
		for(i=1;i<n;i++)
		{
			scanf("%s%d ",&a,&m);    // 输入城市名和与之相连的城市个数
			for(j=0;j<m;j++)
			{
				scanf("%s%d ",&b,&c);   // 与之相连的城市名和距离
				map[a[0]-'A'][b[0]-'A']=map[b[0]-'A'][a[0]-'A']=c;
			}
		}
		prim();
	}
	return 0;
}</span>

Kruskal算法

<pre name="code" class="cpp"><span style="font-size:18px;">/*
kruskal
Memory 172K
Time    0MS
*/
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAXM 900
#define MAXV 30

typedef struct
{
	int s,t,w;
}Edge;

int n,esum,set[MAXV];
Edge edge[MAXM];

int find(int x)
{
	int rt;
	if(set[x]!=x)
    {
		rt=find(set[x]);
		set[x]=rt;
		return set[x];
	}
	else return x;
}

bool Union(int a,int b)
{
	int fa,fb;
	fa=find(a);		//这里用并查集来判断是否有环
	fb=find(b);
	if(fa==fb) return 0;		//构成环了,这条边不能加进来
	set[fa]=fb;     // 保存老大
	return 1;
}

void kruskal()
{
	int i,ans=0;
	for(i=0;i<esum;i++)
    {
		if(Union(edge[i].s,edge[i].t))
		{
			//如果将这条边加进来构成不了环就加进来
			//还可以加一个计数,加到n-1就退出循环,如果不足n-1就构成不了生成树
			ans+=edge[i].w;
		}
	}
	printf("%d\n",ans);
}

int cmp(const void * a,const void *b)
{
	return (*(Edge*)a).w-(*(Edge*)b).w;
}

int main()
{
	int i,j,m,c;
	char a[2],b[2];
	while(scanf("%d",&n) && n)
    {
		esum=0; // 表示输入边的个数
		for(i=0;i<=n;i++)
            set[i]=i;
		for(i=1;i<n;i++)
		{
			scanf("%s%d ",&a,&m);
			for(j=0;j<m;j++)
			{
				scanf("%s%d ",&b,&c);
				edge[esum].s=a[0]-'A';
				edge[esum].t=b[0]-'A';
				edge[esum++].w=c;
			}
		}
		qsort(edge,esum,sizeof(edge[0]),cmp);		//首先对所有边的权值从小到大排序
		kruskal();
	}
	return 0;
}
</span>


 

有问题不要忘记留言






1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看READme.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值