【POJ 1251】 Jungle Roads 最小生成树 Prim

Jungle Roads

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33507 Accepted: 15659

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 
 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题意:给你一个数字n,代表有n个村庄,接下来有n-1行,每一行的第一个字符为一个村庄,第二个数字代表与这个村庄相连的村庄的个数,接下来字符分别是与第一个字符表示的村庄相连的村庄,数字代表权值。如第一组数据:A 2 B 12 I 25 代表与A村庄相连的村庄有两个B,I。 A、B村庄之间的权值w(A,B)=12,A、I村庄之间的权值w(A,I0)=25。

题解:这就是一道最小生成树的题。但是坑就坑在数据输入的处理,笔者第一次用%c来处理数据的输入,结果数据全过。写模板五分钟,改Bug一小时。这道题还是推荐使用%s。字符串数据的输入有时候处理不好,导致结果全对,但是就是找不出来因为输入数据处理不当的bug。

#include<cstdio>        
#include<cstring>
using namespace std;
const int maxn=1000+7;
const int INF=0x7f7f7f7f;
int cost[maxn][maxn];
int low[maxn];
int vis[maxn];
int n,m,w;
char c1[2],c2[2];
int prim()
{
    int min ,pos,res=0;
    for(int i=0;i<n;i++) vis[i]=0;
    vis[0]=1;
    for(int i=1;i<n;i++)  low[i]=cost[0][i];
    for(int i=1;i<n;i++){
        min=INF,pos=-1;
        for(int j=0;j<n;j++){
            if(vis[j]==0&&low[j]<min){
                min=low[j];
                pos=j;
            }
        }
        if(min==INF)  return -1;
        res+=min;
        vis[pos]=1;
        for(int j=0;j<n;j++){          //更新 
            if(vis[j]==0&&low[j]>cost[pos][j]){
                low[j]=cost[pos][j];
            }
        }
    }
    return res;
}
int main()
{
    while(scanf("%d",&n)==1&&n){
        getchar();
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(i==j) cost[i][j]=0;          //对角线就是自己 初始化为0
                else cost[i][j]=INF;         //其余初始化为 INF
            }
        }
        for(int i=0;i<n-1;i++){
            scanf("%s%d",c1,&m);
            for(int j=0;j<m;j++){
                scanf("%s%d",c2,&w);
                cost[c1[0]-'A'][c2[0]-'A']=cost[c2[0]-'A'][c1[0]-'A']=w;
            }
        }
        int res=prim();
        printf("%d\n",res);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值