HDU 5546 dfs深搜四连块

Ancient Go

Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The chess of the same color makes connected components(connected by the board lines), for each of the components, if it’s not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When one of the player makes his move, check the opponent’s components first. After removing the dead opponent’s components, check with the player’s components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It’s Yu Zhou’s move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu’s chess.

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents an empty cell. ′x′ represents a cell with black chess which owned by Yu Zhou. ′o′ represents a cell with white chess which owned by Su Lu.

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.
Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.

Sample Input
2

…….xo
………
………
..x……
.xox….x
.o.o…xo
..o……
…..xxxo
….xooo.

……ox.
…….o.
…o…..
..o.o….
…o…..
………
…….o.
…x…..
……..o

Sample Output
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu’s component.

In the second test case, there is no way to kill Su Lu’s component.

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=5546

题目大意

给个9x9的棋盘,判断'x'能不能一步就杀死'o'。

题解

dfs求连通块,从每一个'o'出发dfs,计算周围'.'的个数,注意是4连块不是8连块,每次dfs前要清空used,遍历过的'.'一定要标记,否则会重复计算。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <stack>
#include <queue>
#include <vector>
#define INF 0x3f3f3f3f 
using namespace std;
const int maxn = 10;
char pic[maxn][maxn];
int used[maxn][maxn];
int m=9, n=9;
int dr[4] = {-1,0,1,0};
int dc[4] = {0,1,0,-1};

void dfs(int r, int c, int &cnt){
    if(r<0 || r>=m || c<0 || c>=n) return;
    if(used[r][c]) return;
    if(pic[r][c] == 'x') return;
    if(pic[r][c] == '.'){
        used[r][c] = 1;//标记'.'
        cnt ++;
        return;
    }
    used[r][c] = 1;
    for(int i=0; i<4; i++){
        dfs(r+dr[i], c+dc[i], cnt);
    }
}

int main(){
    int t;
    scanf("%d", &t);
    for(int cas = 1; cas<=t ; cas++){
        for(int i=0; i<m; i++){
            scanf("%s", pic[i]);
        }
        int flag = 0;
        for(int i=0; i<m; i++){
            for(int j=0; j<n; j++){
                memset(used, 0, sizeof(used));//清空used
                if(pic[i][j] == 'o'){
                    int cnt = 0;
                    dfs(i, j, cnt);
                    if(cnt == 1){
                        flag = 1;
                        break;
                    }
                }
            }
        }
        if(flag){
            printf("Case #%d: Can kill in one move!!!\n", cas);
        }
        else{
            printf("Case #%d: Can not kill in one move!!!\n", cas);
        }
    }
    return 0;
} 
/*
以下是测试样例,如果都能过程序应该就没问题了
......... 
......... 
......... 
......... 
...xxx... 
..xooox.. 
..xxo.... 
....x.... 
......... 

o.o...ox. 
x......o. 
o.xo..... 
..oxo.... 
...o..... 
......... 
.......o. 
o........ 
oox...... 

ooooooooo 
xx.xxxxx. 
xxxo..... 
......... 
......... 
......... 
......... 
......... 
......... 

......... 
...xx.... 
..xoox... 
..xox.... 
....xx... 
..xooo... 
...xxx... 
......... 
......... 


..x.x.... 
.xo.ox... 
.xooox... 
..xxx.... 
......... 
......... 
......... 
......... 
......... 
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值