PAT L1-039. 古风排版 数组填字符

L1-039. 古风排版

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)

输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
ce s

题目链接:https://www.patest.cn/contests/gplt/L1-039

题解:

    把输入的字符串从最后一列开始填入数组中,最后输出整个数组就行了。填字符的时候有几个注意点:
    (1)c=len%r != 0时c++(多余一列字符填不满)
    (2)超出line.size()时填入‘ ’

//#include <bits/stdc++.h>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<sstream>
#include<iostream>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

const int maxn = 105;
char a[maxn][maxn];

int main(){
    int r;
    string line;
    while(scanf("%d", &r) == 1 && r){
        getline(cin, line);
        getline(cin, line);
        int len = line.size();
        int c = len/r;
        if(len%r != 0){
            c++;
        }
        int cnt = 0;
        for(int j=c; j>=1; j--){
            for(int i=0; i<r; i++){
                if(cnt<len){
                    a[i][j] = line[cnt++];
                }
                else a[i][j] = ' ';
            }
        }
        for(int i=0; i<r; i++){
            for(int j=1; j<=c; j++){
                printf("%c", a[i][j]);
            }
            printf("\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值