HDU3714 - Error Curves - 三分

1.题目描述:

Error Curves

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5439    Accepted Submission(s): 2057


Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input
  
  
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output
  
  
0.0000 0.5000
 

Author
LIN, Yue
 

Source
 

Recommend
zhouzeyong
 
2.题意概述:

给定一些函数y = a * x^2 + b * x + c ( a >= 0 ),其中x范围 是 [0, 1000]问你对于每个xi所在函数yi他们的最大值是Yki,由Yki组成的点在这段区间中的最小值是多少?

3.解题思路:

由于a大于0,所以这些函数都是开口向上的,所以对于区间内的这些二次函数的最大值构成的这个函数其实也是开口向上的,我们要找的就是它的最小值了。可以用三分解决。

4.AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define mod 10000
#define maxn 111111
#define eps 1e-15
#define pi acos(-1.0)
struct node
{
	int a, b, c;
}p[maxn];
double judge(double  x, int n)
{
	double  Max = p[0].a*x*x + p[0].b*x + p[0].c;
	for (int i = 1; i < n; i++)
		Max = max(Max, p[i].a*x*x + p[i].b*x + p[i].c);
	return Max;
 }
int main()
{
//	freopen("in.txt", "r", stdin);
//	freopen("out.txt", "w", stdout);
	int t, n;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d%d%d", &p[i].a, &p[i].b, &p[i].c);
		double l = 0, r = 1000, m, mm;
		for (int i = 0; i <= 100; i++)
		{
			m = l + (r - l) / 2;
			mm = m + (r - m) / 2;
			if (judge(m, n) < judge(mm, n))  
				r = mm;
			else  
				l = m;
		}
		printf("%.4lf\n", judge(l, n));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值