hdu 3714 三分法

Error Curves

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3158    Accepted Submission(s): 1201



Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input
  
  
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output
  
  
0.0000 0.5000
 

Author
LIN, Yue
 

Source
 

题意:题意很抽象,不是很容易看懂,这题给n个二项式,定义F(x)为x在(0,1000),函数F[x]=max{Si(x)}  (i=0,1,2,3,...,n)    其中Si(x)为二次函数, 求函数F[X]的最小值。

解题思路:用三分得到的mid1,mid2,分别到Si(x)中找最大值。

代码如下:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#define maxn 10010
#define eps 1e-15
#include <algorithm>
using namespace std;

double a[maxn],b[maxn],c[maxn];
int n;

double cal(double x)
{
    int i;
    double ans=a[0]*x*x+b[0]*x+c[0];
    for(i=1;i<n;i++)
        ans=max(ans,a[i]*x*x+b[i]*x+c[i]);
    return ans;
}

double solve()
{
    double left,right,mid,midmid;
    double mid_area,midmid_area;
    left=0.0;right=1000.0;
    while(left+eps<right)
    {
        mid=(left+right)/2;
        midmid=(mid+right)/2;
        mid_area = cal(mid);
        midmid_area = cal(midmid);
        if(mid_area>midmid_area)
            left = mid;
        else
            right = midmid;
    }
    return cal(right);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i;
        double ans=0.0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
        ans = solve();
        printf("%.4lf\n",ans);
    }
    return 0;
}

注意事项:比较double型数大小的时候,最好这样 left+eps<right 来比较,eps为很小很小的一个数(1e-15)

附三分法求极值原理:

二分法适用于求单调的时候用的,就比如说排序好的数组,那是递增的或者递减的。如果像出现了下图二次函数那样的怎么求他的最值呢?

        二分法早就失去了他的意义了。不过还是可以用三分法来实现的,就是二分中再来二分。比如我们定义了LRmid = (L + R) / 2midmid = (mid + R) / 2; 如果midmid靠近极值点,则R = midmid;否则就是mid靠近极值点,则L = mid;这样的话,极值还是可以求的


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值