POJ 1012

POJ 1012

Joseph
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 16275  Accepted: 6040

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.


Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output

The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input

3
4
0

Sample Output

5
30


Source

Central Europe 1995
----------------------------------------------------------------------------------------------------------------------------
难度: 1       代码:1      分类: 递推+打表
分析:开始没有用打表,tle。后来直接打表,0ms,服务器端打表32ms
题目数据量太小,直接模拟Joseph暴力打表也能过。这里介绍一下递推法测试。
先引入Joseph递推公式,设有n个人(0,...,n-1),数m,则第i轮出局的人为f(i)=(f(i-1)+m-1)%(n-i+1),f(0)=0;依次我们可以来做测试,只要前k轮中只要有一次f(i)<k则此m不符合题意。接下来我们考察一下只剩下k+1个人时候情况,那么依题意则这一轮出局的人要么在上一轮出局人的左边,要么就在右边,设上一轮出局的人为x,则必有m%(k+1)==0或1(还不明白就看下面两个序列表示的k+2人的情况(G表示好人,共有k个,B表示坏人,X表示上一轮出局的人)GG....GGBX,GG...GGXB)。所以测试数为t(k+1)或t(k+1)+1,t>=1。
代码:
直接打表
#include  < stdio.h >

int  x[]  =   27530169441187276321740933134599011358657,  2504881 } ;

int  main()
{
    
int n;
    
    
while(scanf("%d"&n),n)
    
{    
        printf(
"%d ", x[n-1] );    
    }

    
return 0;
}

服务器端打表

#include  < stdio.h >

int  test( int  k, int  m)
{
    
int i,j=0,n=k<<1;
    
for(i=0;i<k;i++)
    
{
        j
=(j+m-1)%(n-i);
        
if(j<k) return 0;
    }

    
return 1;
}


int  main()
{
    
int i,j,k;
    
int x[13];
    
for(k=1;k<14;k++)
    
{
        i
=k+1;
        
while(1)
        
{
            
if(test(k,i)) 
            
{
                x[k
-1]=i;
                
break;
            }

            
if(test(k,i+1))
            
{
                x[k
-1]=i+1;
                
break;
            }

            i
+=(k+1);
        }

    }


    
while(scanf("%d",&k),k)
    
{
        printf(
"%d ",x[k-1]);
    }

}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值