HDU-5014-Number Sequence

Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 

思路:从最大的一个数开始找能配对使他们的异或值最大的一个数即可。幸亏比赛的时候不是我敲,因为longlong WA 了好几发。

#include <stdio.h>

int num[100005],d[100005];

int main()
{
    int n,i,j,t;
    long long ans;

    while(~scanf("%d",&n))
    {
        for(i=0;i<=n;i++) d[i]=-1;

        for(i=0;i<=n;i++) scanf("%d",&num[i]);

        ans=0;

        for(i=n;i>=0;i--)
        {
            if(d[i]==-1)
            {
                t=0;

                for(j=0;;j++)
                {
                    if(!(i&(1<<j))) t+=1<<j;

                    if(t>=i) break;
                }

                t-=(1<<j);

                ans+=(i^t)+(i^t);

                d[i]=t;
                d[t]=i;
            }
        }

        printf("%I64d\n",ans);

        for(i=0;i<n;i++) printf("%d ",d[num[i]]);

        printf("%d\n",d[num[n]]);
    }
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值