hdu.Number Sequence


Problem Description

A number sequence is defined asfollows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple testcases. Each test case contains 3 integers A, B and n on a single line (1 <=A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end ofinput and this test case is not to be processed.

Output

For each test case, print the value off(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

 

如果用递归来做的话是要超时的

本题存在循环,我们找到第一个循环,算出多少一循环就好说了

另外 f(n) = x / 7; 说明f(n) 可能等于0 1 2 3 4 5 6

那个f(n-1)f(n)最多的组合是7 – 7 = 49,可以知道循环最大为49,可以增加代码效率

以下代码:

#include<stdio.h>

intmain()

{

    int i, a, b, n;

    char f[50];

    while(scanf("%d %d %d",&a,&b ,&n) != EOF)

    {

        if(a == 0 && b == 0 &&n == 0)

        break;

        f[0] = 1;

              f[1] = 1;

        if(n == 1 || n == 2)

              {

            printf("1\n");

            continue;

        }

        for(i = 2; i <= 49; i++)

        {

            f[i] = (a * f[i - 1] + b * f[i -2]) % 7;

            if (f[i - 2] == 1 && f[i -1] == 1 && i != 2)     //找到第二组1 1 循环=i – 2,找到后break

                            break;

        }

        printf("%d\n",f[(n - 1) % (i- 2)]);

    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值