6112 Problem C Be Unique (20)

389 篇文章 1 订阅
144 篇文章 2 订阅

问题 C: Be Unique (20)
时间限制: 1 Sec 内存限制: 32 MB
献花: 64 解决: 39
[献花][花圈][TK题库]
题目描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
输入
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
输出
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
样例输入
7 5 31 5 88 67 88 17
5 888 666 666 888 888
样例输出
31
None

#include <iostream>
#include <fstream>
#include <algorithm>
using namespace std;

const int MaxN = 100001;

int main()
{
#ifdef _DEBUG
    ifstream cin("data.txt");
#endif // _DEBUG

    int N, Num, data[MaxN], NC ,index;
    while (cin >> N)
    {
        int Table[MaxN] = { 0 };
        NC = 0;
        while (N--)
        {
            cin >> Num;
            data[NC++] = Num;
            ++Table[Num];
        }
        for (index = 0; index < NC; ++index)
        {
            if (Table[data[index]] == 1)
            {
                printf("%d\n", data[index]);
                break;
            }
        }
        if (index == NC)
            printf("None\n");
    }

#ifdef _DEBUG
    cin.close();
    system("pause");
#endif // _DEBUG

    return 0;
}
/**************************************************************
    Problem: 6112
    User: Sharwen
    Language: C++
    Result: 升仙
    Time:81 ms
    Memory:2368 kb
****************************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值