1043. Is It a Binary Search Tree (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1043. Is It a Binary Search Tree (25)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>

using namespace std;
const int MaxN = 1010;


typedef struct tnode
{
    int v;
    struct tnode * lchild;
    struct tnode * rchild;
}TNode;

void Insert(TNode *&Root,int val)
{
    if(!Root)
    {
        Root = new TNode;
        Root->v = val;
        return;
    }

    if(Root->v > val)
        return Insert(Root->lchild,val);
    else
        return Insert(Root->rchild,val);
}


TNode * CreateTree(int Data[],int n)
{
    TNode * root = NULL;
    for(int i=0;i<n;++i)
        Insert(root,Data[i]);

    return root;
}

int pre[MaxN],Mirror[MaxN];
void preOrder(TNode * root,int &k)
{
    if(!root) return;
    pre[k++] = root->v;
    preOrder(root->lchild,k);
    preOrder(root->rchild,k);
}

void MirrorOrder(TNode * root,int &k)
{
    if(!root) return;
    Mirror[k++] = root->v;
    MirrorOrder(root->rchild,k);
    MirrorOrder(root->lchild,k);
}

bool Equal(int a[],int b[],int n)
{
    for(int i=0;i<n;++i)
    {
        if(a[i]!=b[i])
            return false;
    }
    return true;
}

void PostOrder(TNode * root,int &curn,int n)
{
    if(!root) return;

    PostOrder(root->lchild,curn,n);
    PostOrder(root->rchild,curn,n);

    cout << root->v;++curn;
    if(curn != n) cout << " ";
}

void MirrorPostOrder(TNode * root,int &curn,int n)
{
    if(!root) return;

    MirrorPostOrder(root->rchild,curn,n);
    MirrorPostOrder(root->lchild,curn,n);

    cout << root->v;++curn;
    if(curn != n) cout << " ";
}

int main()
{
#ifdef _Debug
freopen("data.txt","r+",stdin);
#endif

    std::ios::sync_with_stdio(false);

    int n,seq[MaxN],k;

    cin >> n;

    for(int i=0;i<n;++i)
        cin >> seq[i];

    TNode *root = CreateTree(seq,n);

    k=0;
    preOrder(root,k);
    k = 0;
    MirrorOrder(root,k);

    int tmp = 0;
    if(Equal(pre,seq,n))
    {
        cout << "YES" <<endl;
        PostOrder(root,tmp,n);
    }
    else if(Equal(Mirror,seq,n))
    {
        cout << "YES" <<endl;
        MirrorPostOrder(root,tmp,n);

    }
    else
        cout << "NO";
    return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值