【九度OJ】题目1439:Least Common Multiple 解题报告

91 篇文章 0 订阅
90 篇文章 33 订阅

【九度OJ】题目1439:Least Common Multiple 解题报告

标签(空格分隔): 九度OJ


原题地址:http://ac.jobdu.com/problem.php?pid=1439

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:

2
3 5 7 15
6 4 10296 936 1287 792 1

样例输出:

105
10296

Ways

BigInteger类好!

这个题的意思很简单,其实就是求指定数字的最小公倍数。

我们可以利用上一题的经验,求出m个数的共同最小公倍数即可。

做题时一个错误的地方就是注意两层循环的嵌套,把循环变量给写错了,导致一直出错。

import java.util.*;
import java.math.*;

public class Main{
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        String n = scanner.nextLine();
        for (int i = 0; i < Integer.parseInt(n); i++) {
            String line = scanner.nextLine();
            String[] params = line.split(" ");
            BigInteger a = new BigInteger(params[1]);
            for (int j = 2; j < params.length; j++) {
                BigInteger b = new BigInteger(params[j]);//是j,不是i
                a = a.multiply(b).divide(a.gcd(b));
            }
            System.out.println(a.toString());
        }
    }
}

本来以为C++的版本也会同样的容易,可是还是遇到点问题,很不爽。原因是因为结果超出了int范围。改成long long就好了。

#include <stdio.h>

long long gcd(long long a, long long b) {
    return b != 0 ? gcd(b, a % b) : a;
}

int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        while (n-- != 0) {
            int m;
            scanf("%d", &m);
            long long answer = 1;
            while (m-- != 0) {
                int temp;
                scanf("%d", &temp);
                answer = answer * temp / gcd(answer, temp);
            }
            printf("%lld\n", answer);
        }
    }
    return 0;
}

Date

2017 年 3 月 7 日

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值