Program2_1004

 我现在做的是第二专题编号为1004的试题,试题内容如下所示:

 

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.<br>We all like toxophily.<br><br>Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?<br><br>Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. <br>
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.<br>Technical Specification<br><br>1. T ≤ 100.<br>2. 0 ≤ x, y, v ≤ 10000. <br>
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.<br>Output "-1", if there's no possible answer.<br><br>Please use radian as unit. <br>
 

Sample Input
  
  
3<br>0.222018 23.901887 121.909183<br>39.096669 110.210922 20.270030<br>138.355025 2028.716904 25.079551<br>
 

Sample Output
  
  
1.561582<br>-1<br>-1<br>
 
简单题意:

给出 一个点 x ,y 坐标,给出初速度。求从坐标原点以什么角度斜上抛运动可以达到那个点。

解题思路:

 

首先运用物理知识,写出运动轨迹方程,然后就可以  代入所给点,判断此点位置,也就是二分求角度。

或者可以把上式再转化一下,变成一个一元二次方程,讨论解的个数即可。

编写代码:

  
    #include<iostream>
    #include<algorithm>
    #include<math.h>
    #include<string.h>

    using namespace std;
    double PI=acos(-1.0);

    int main()
    {

        double x,y,v,a,b,c,t,x1,x2;
        int n;
        cin>>n;
        cout.precision(6);
        while(n--)
        {
            cin>>x>>y>>v;
            if(x==0&&y==0)
              cout<<0<<endl;
            else
            {
                a=x*x*(9.8/(2*v*v));
                b=-1*x;
                c=y+a;
                t=b*b-4*a*c;
                if(t<0)
                   cout<<-1<<endl;
                else
                {
                    x1=(-1*b-sqrt(t))/(2*a);
                    x2=(-1*b+sqrt(t))/(2*a);
                    if(x1>=0)
                    {
                        if(x2>=0)
                            x1=min(x1,x2);
                        cout << fixed << atan(x1) << endl;
                    }
                    else if(x2 >=0)
                       cout << fixed << atan(x2) << endl;
                    else
                        cout<<-1<<endl;

                }
            }
        }
        return 0;


    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值