PTA甲 1103. Integer Factorization (30)

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

这道题不错可以先求个字典然后再,适当剪枝通过。昨天睡得比较晚所以头有一些昏,日后我会完善这道题的剪枝。


#include <iostream>

#include <cstdio>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;


const int maxn = 405;


int n,k,p;
int fact[maxn];
int res[maxn];
int ans[maxn];
int temp=1;
int fit=0;
int maxnu=0;
int flag=0;


void dfs(int num,int cnt,int last,int sum)
{
if(num==0&&cnt==0)
{
flag=1;
if(sum>maxnu)
{
maxnu=sum;
for (int i = 1; i <= k; ++i)
{
ans[i]=res[i];
}
}
return;
}
else if (cnt==0)
{
return;
}
for(int i=last;i>=0;i--)
{
int left=num-fact[i];
if(left>=cnt-1)
{
res[cnt]=i+1;
dfs(left,cnt-1,i,sum+i+1);
}
}


}


int main()
{
scanf("%d%d%d",&n,&k,&p);






while(temp<=n)
{
fact[fit]=temp;
fit++;
temp=pow(fit+1,p);
}


int last=fit-1;
dfs(n,k,last,0);
if (flag)
{
printf("%d = %d^%d",n,ans[k],p);
for (int i = k-1; i>0; i--)
{
printf(" + %d^%d",ans[i],p);
}
}
else
{
printf("Impossible\n");
}


return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值