北大ACM poj1050 To the Max(C++)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32446 Accepted: 16930

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
#include<stdio.h>
int s[100],n;
int zxl()//计算子矩阵最大子序列的和 
{
         int sum=0;
         int max=-100000;
         for(int i=0;i<n;i++)
         {
             sum+=s[i];
             if(sum>max)
                max=sum;
             if(sum<0)
		        sum=0;
         }
         return max;
}

int main()
{
    int a[110][110],max1;
    while(scanf("%d",&n)!=EOF)
    {
    	max1=-99999;
        for(int i=0;i<n;i++)
           for(int j=0;j<n;j++)
             scanf("%d",&a[i][j]);//输入矩阵 
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                 s[j]=a[i][j];
            max1=zxl()>max1?zxl():max1;
            for(int j=i+1;j<n;j++)
            {
                for(int k=0;k<n;k++)
                 s[k]+=a[j][k];
                 max1=zxl()>max1?zxl():max1;
            }
        }
          printf("%d\n",max1);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值