北大ACM poj2081 Recaman's Sequence

Recaman's Sequence

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

 

 

/*解题思路:

       题目给出了一个序列的生成方法,求序列的第k个元素。

       k不大,直接递推生成第K个元素就可以了。

       生成过程中需要记录已经被生成的元素,可以用布尔数组打表记录

代码如下:
*/
#include<stdio.h>
int A[500005];
int table[3500000]={0};
void init()
{
      int i,t;
      A[0]=0;
      for(i=1;i<=500000;i++)
      {
            t=A[i-1]-i;
            if(t>0&&!table[t])
                  A[i]=t;
            else
                  A[i]=A[i-1]+i;
            table[A[i]]=1;
      }
}
int main()
{
      int n;
      init();//初始化,打表 
      while(scanf("%d",&n) && n!=-1)//输入-1结束 
      {
            printf("%d\n",A[n]);
      }
      return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值