UVA - 694 The Collatz Sequence(水题)


  The Collatz Sequence 

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:
Choose an arbitrary positive integer  A as the first item in the sequence.
Step 2:
If  A = 1 then stop.
Step 3:
If  A is even, then replace  A by  A / 2 and go to step 2.
Step 4:
If  A is odd, then replace  A by 3 *  A + 1 and go to step 2.

It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of  A  (for step 1) and the second giving  L , the limiting value for terms in the sequence. Neither of these,  A  or  L , is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of  A  is always less than  L . A line that contains two negative integers follows the last case.

Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for  A , the limiting value  L , and the number of terms computed.

Sample Input 

 3 100
 34 100
 75 250
 27 2147483647
 101 304
 101 303
 -1 -1

Sample Output 

 Case 1: A = 3, limit = 100, number of terms = 8
 Case 2: A = 34, limit = 100, number of terms = 14
 Case 3: A = 75, limit = 250, number of terms = 3
 Case 4: A = 27, limit = 2147483647, number of terms = 112
 Case 5: A = 101, limit = 304, number of terms = 26
 Case 6: A = 101, limit = 303, number of terms = 1
 
 
题目大意:
输入两个数A和L,按照以下进行循环运算,问最后结束循环时一共进行了多少次运算?

 
 
  1. 若A为1或者A>L,则推出。
  2. 若A为偶数,则A=A/2。
  3. 若A为奇数,则A=3*A+1。
注意:
  1. 最后的1也算一项。
  2. 如果某个A>limit,那么此项不计入。
  3. 3*A+1很可能会溢出,所以要用long long进行保存。


#include <stdio.h>

int main() {
	long long a,l,t;
	int cnt,cas = 1;
	while(scanf("%lld%lld",&a,&l) != EOF) {
		if(a == -1 && l == -1) {
			break;
		}
		cnt = 0;
		t = a;	
		while( a != 1 && a <= l) {
			if(a % 2 == 0) {
				a = a / 2;
			}else if(a % 2 == 1) {
				a = 3 * a + 1;
			}
			cnt++;
		}
		if(a == 1) {
			cnt++;
		}
		printf("Case %d: A = %lld, limit = %lld, number of terms = %d\n",cas++,t,l,cnt);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值