Uva11292 The Dragon of Loowater

16 篇文章 0 订阅

Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem. The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geesepopulationwasoutofcontrol. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance. One day, a freak mutation occurred, and one of the geese spawned a multi-headed firebreathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom. The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.” Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!


Input Theinputcontainsseveraltestcases. Thefirstlineofeachtestcasecontainstwointegersbetween1and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres. The last test case is followed by a line containing ‘0 0’.

Output For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’. 

Sample Input

 2 3 

5

4

7

2 1 

10 

0 0 

Sample Output 

11 

Loowater is doomed!


王国里面有一条n个头的龙,需要雇一些骑士将它杀死(即砍掉所有的头),有m个骑士可以雇佣,一个能力值为x的骑士可以砍掉恶龙一个直径不超过x的头,且需要支付x个金币。一个武士只能砍掉一个头,不能被雇用两次。就是根据给出的恶龙每个头的直径和m个骑士的能力,编写程序得出需要支付的最少金额。


这题不难,在这里用两个数组分别存放恶龙头的直径和骑士的能力,然后分别将其从小到大排序,然后分别遍历,遍历到的骑士能力只需要大于等于恶龙头的直径就ok,其实能力小于恶龙头的直径就不需要雇佣,雇用过的不能再次雇佣。如果最后便利完了所有的骑士能力,仍有恶龙的头不能被砍掉,则无解,输出“Loowater is doomed!”

代码如下:

#include <stdio.h>
#include <stdlib.h>
#define maxn 200000
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int a[maxn],b[maxn];

int cmp(const void*a,const void*b)
{
	return *(int*)a-*(int*)b;
}
int main(int argc, char *argv[]) 
{
	int n,m,c;
	int i,j;
	while((scanf("%d%d",&n,&m))!=-1&&n+m!=0)
	{
		c=0;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		qsort(a,n,sizeof(int),cmp);
		for(j=0;j<m;j++)
			scanf("%d",&b[j]);
		qsort(b,m,sizeof(int),cmp);
		j=0;
		for(i=0;i<m;i++)
		{
			if(b[i]>=a[j])
			{
				c+=b[i];
				if(++j==n)
					break;
			}
		}
		if(j<n)
			printf("Loowater is doomed!\n");
		else
		 	printf("%d\n",c);
	}
	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值