uva 11292The Dragon of Loowater

Once upon a time, in the
Kingdom of Loowater, a mi-
nor nuisance turned into a
major problem.
The shores of Rellau
Creek in central Loowater
had always been a prime
breeding ground for geese.
Due to the lack of predators,
the geese population was out
of control. The people of
Loowater mostly kept clear
of the geese. Occasionally,
a goose would attack one of
the people, and perhaps bite
off a nger or two, but in
general, the people tolerated
the geese as a minor nui-
sance.
One day, a freak mu-
tation occurred, and one
of the geese spawned a
multi-headed re-breathing
dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp.
Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon
and save the kingdom.
The knights explained: \To slay the dragon, we must chop off all its heads. Each knight can chop
off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a
head, a knight must be at least as tall as the diameter of the head. The knights' union demands that
for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the
knight's height."
Would there be enough knights to defeat the dragon? The king called on his advisors to help him
decide how many and which knights to hire. After having lost a lot of money building Mir Park, the
king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to
help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to
a crisp!
Input
The input contains several test cases. The rst line of each test case contains two integers between 1 and
20000 inclusive, indicating the number
n
of heads that the dragon has, and the number
m
of knights in
the kingdom. The next
n
lines each contain an integer, and give the diameters of the dragon's heads,
in centimetres. The following
m
lines each contain an integer, and specify the heights of the knights of
Loowater, also in centimetres.
The last test case is followed by a line containing `
0 0
'.
Output
For each test case, output a line containing the minimum number of gold coins that the king needs to
pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the
line `
Loowater is doomed!
'.
SampleInput
2 3
5
4
7
8
4
2 1
5
5
10
0 0
SampleOutput
11
Loowater is doomed!


先排序 贪心

WA了两次

例如

2   4   4   5

2   3   4   4   5

中间这个3是不可取的

就在这里错了,一开始没想到


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 20010
int x[N], y[N], mark[N];
int cmp(const void *a, const void *b) {
	return (*(int *)a - *(int *)b);
}
int main(){
	int a, b;
	while (scanf("%d%d", &a, &b) != EOF) {
		if (a == 0 && b == 0)
			break;
		memset(x, 0, sizeof(x));
		memset(y, 0, sizeof(y));
		memset(mark, 0, sizeof(mark));
		for (int i = 0; i < a; i++)
			scanf("%d", &x[i]);
		for (int i = 0; i < b; i++)
			scanf("%d", &y[i]);
		qsort(x, a, sizeof(x[0]), cmp);
		qsort(y, b, sizeof(y[0]), cmp);
		int mark1 = 0, count = 0, n = 0;
		for (int i = 0; i < a; i++)
			for (int j = mark1; j < b; j++)
				if(x[i] <= y[j]) {
					count++;
					mark1 = j + 1;
					mark[n++] = y[j];
					break;
				}
		if (count < a)
			printf("Loowater is doomed!\n");
		else {
			int sum = 0;
			for (int i = 0; i < n; i++)
				sum += mark[i];
			printf("%d\n", sum);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值