POJ 2478 Farey Sequence(欧拉函数)

                                                                                                                              Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11802 Accepted: 4597

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

 

 

/*对于每一个输入的n,结果输出为
从2开始的欧拉函数值一直加到n的欧拉函数值,
为了对于不同的n,这个累加的过程不再重复,
我们将累加的结果存储在数组a之中*/
/*注意,由于是累加,因此累加后的结果很大,最终
要求的答案也可能很大,超出int的范围,因此要用long long*/
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=1000000+10;
int phi[maxn];//用来存储欧拉函数值
long long int a[maxn];//用来存取结果
int n;//表示点横坐标和纵坐标在0-n范围内
int main()
{
 void phi_table(int);
 void a_table(int);
 phi_table(maxn-1);/*注意这里的参数不要写成maxn,因为maxn为数组的大小,最大下标为maxn-1,所以所能求的
                     最大数为maxn-1的欧拉函数*/
 a_table(maxn-1);
 while(cin>>n)
 {
  if(n==0){break;}
  long long int ans=a[n];
  cout<<ans<<endl;
 }
 return 0;
}


void phi_table(int n)
{
 int i,j;
    for(i=2;i<=n;i++)phi[i]=0;
    phi[1]=1;
    for(i=2;i<=n;i++)
        if(!phi[i])
            for(j=i;j<=n;j+=i)
            {
                if(!phi[j])phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
}

void a_table(int n)
{
 int i;
 a[0]=a[1]=0;
 a[2]=phi[2];
 for(i=3;i<=n;i++)
 {a[i]=a[i-1]+phi[i];}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值