第一章例题4墓地雕塑UVa1388(参照系的选取)

1388 - Graveyard

Time limit: 3.000 seconds

Programming contests became so popular in the year 2397 that the  governor of New Earck -- the largest human-inhabited planet of the galaxy  -- opened a special Alley of Contestant Memories (ACM) at the local  graveyard. The ACM encircles a green park, and holds the holographic  statues of famous contestants placed equidistantly along the park perimeter.  The alley has to be renewed from time to time when a new group of  memorials arrives.

When new memorials are added, the exact place for each  can be selected arbitrarily along the ACM, but the equidistant  disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the  graveyard keepers believe the holograms are holding dead people souls,  and thus always try to renew the ACM with minimal possible movements of  existing statues (besides, the holographic equipment is very heavy).  Statues are moved along the park perimeter. Your work is to find a  renewal plan which minimizes the sum of travel distances of all statues.  Installation of a new hologram adds no distance penalty, so choose the  places for newcomers wisely!

Input

The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n -- the number of  holographic statues initially located at the ACM, and m -- the number of  statues to be added (2$ \le$n$ \le$1000, 1$ \le$m$ \le$1000). The length of the  alley along the park perimeter is exactly 10 000 feet.

Output

For each test case, write to the output a line with a single real number -- the minimal sum of  travel distances of all statues (in feet). The answer must be precise to  at least 4 digits after decimal point.

\epsfbox{p3708.eps}

Pictures show the first three examples. Marked circles denote original  statues, empty circles denote new equidistant places, arrows denote  movement plans for existing statues.

Sample Input

2 1 
2 3 
3 1 
10 10

Sample Output

1666.6667 
1000.0 
1666.6667 
0.0

 

/*我个人认为这道题是涉及到参照系的选取和double数据的取整
这道题我们要巧妙地选取n+m个雕塑时的情况为基本的坐标系,
并选取原点0坐标,其余的为1,2,。。。n+m-1;
原来n个点的时候,这n个点在n+m坐标系里的坐标
应该是0,k,2k,3k,....(n-1)k,其中k=(n+m)/n,是距离的比率
我们可以通过floor(pos+0.5)类似于四舍五入的方法选取在m+n坐标系里的最近点
再用自己的坐标和最近点的坐标作差并将所有的差值累加即可
*/

/*那么我们自然要问,会不会出现原来n坐标系中的两个点同时移动到m+n坐标系中的同一个点上呢,
答案是否定的,原因是,由于我们用的是floor(pos+0.5)的四舍五入方法选定临近点的,
如果n坐标系里的两个点在m+n坐标系里选取了同一个临近点,证明在m+n坐标系内两者的坐标差值要小于1,
但是我们知道,由于n坐标系更加稀疏,因此两个点之间的距离必然大于1,
因此不存在两个点选了同一个临近点的情况*/
#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
using namespace std;
int n,m;
int main()
{
 while(cin>>n>>m)
 {
  int i;
  double ans=0.0;
  double pos;//用来记录n坐标系内的点在n+m坐标系里的坐标
  double k=(double)(n+m)/n;
  for(i=1;i<n;i++)
  {
   pos=k*i;
   ans+=fabs(pos-floor(pos+0.5));/*四舍五入法选取最近点*/
  }
  ans*=(double)10000/(n+m);
  cout<<setiosflags(ios::fixed)<<setprecision(4)<<ans<<endl;
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值