HDU-4825 Xor Sum &&Codeforces Round #367 (Div. 2) D. Vasiliy's Multiset (Trie树)

Xor Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1427    Accepted Submission(s): 595


Problem Description
Zeus 和 Prometheus 做了一个游戏,Prometheus 给 Zeus 一个集合,集合中包含了N个正整数,随后 Prometheus 将向 Zeus 发起M次询问,每次询问中包含一个正整数 S ,之后 Zeus 需要在集合当中找出一个正整数 K ,使得 K 与 S 的异或结果最大。Prometheus 为了让 Zeus 看到人类的伟大,随即同意 Zeus 可以向人类求助。你能证明人类的智慧么?
 

Input
输入包含若干组测试数据,每组测试数据包含若干行。
输入的第一行是一个整数T(T < 10),表示共有T组数据。
每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。
 

Output
对于每组数据,首先需要输出单独一行”Case #?:”,其中问号处应填入当前的数据组数,组数从1开始计算。
对于每个询问,输出一个正整数K,使得K与S异或值最大。
 

Sample Input
  
  
2 3 2 3 4 5 1 5 4 1 4 6 5 6 3
 

Sample Output
  
  
Case #1: 4 3 Case #2: 4
 

Source
 


对Trie树理解不到位,照着jhz033的套路写了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 2000005;
int a[N][3];
int sz;
void Init()
{
    memset(a,0,sizeof(a));
    sz = 1;
}

void Insert(int x)
{
    int num[35];
    memset(num,0,sizeof(num));
    int cnt = 0;
    while(x)
    {
        num[cnt++] = x % 2;
        x /= 2;
    }
    int u = 0,n = 34;
    for(int i = n;i >= 0;i--)
    {
        if(!a[u][num[i]])
            a[u][num[i]] = sz++;
        u = a[u][num[i]];
    }
}

int Query(int y)
{
    int num[35];
    memset(num,0,sizeof(num));
    int cnt = 0;
    while(y)
    {
        num[cnt++] = y % 2;
        y /= 2;
    }
    for(int i = 0;i <= 34;i++)
        num[i]= num[i] ? 0 : 1;
    int u = 0,n = 34,v,w;
    int ans = 0;
    for(int i = n;i >= 0;i--)
    {
        if(num[i])
        {
            v = 1;
            w = 0;
        }
        else
        {
            w = 1;
            v = 0;
        }

        if(a[u][v])
        {
            u =  a[u][v];
            if(v)
                ans += 1 << i;
        }
        else
        {
            u = a[u][w];
            if(!v)
                ans += 1 << i;
        }
    }
    return ans;
}
int main()
{
    int t,n,m;
    cin >> t;
    for(int ca = 1;ca <= t;ca++)
    {
        Init();
        cin >> n >> m;
        int x,y;
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&x);
            Insert(x);
        }
        printf("Case #%d:\n",ca);
        for(int i = 1;i <= m;i++)
        {
            scanf("%d",&y);
            printf("%d\n",Query(y));
        }
    }
    return 0;
}

Codeforces Round #367 (Div. 2)

D. Vasiliy's Multiset
time limit per test
4 seconds
memory limit per test
256 megabytes
input
standard input
output
standard output

Author has gone out of the stories about Vasiliy, so here is just a formal task description.

You are given q queries and a multiset A, initially containing only integer 0. There are three types of queries:

  1. "+ x" — add integer x to multiset A.
  2. "- x" — erase one occurrence of integer x from multiset A. It's guaranteed that at least one x is present in the multiset A before this query.
  3. "? x" — you are given integer x and need to compute the value , i.e. the maximum value of bitwise exclusive OR (also know as XOR) of integer x and some integer y from the multiset A.

Multiset is a set, where equal elements are allowed.

Input

The first line of the input contains a single integer q (1 ≤ q ≤ 200 000) — the number of queries Vasiliy has to perform.

Each of the following q lines of the input contains one of three characters '+', '-' or '?' and an integer xi (1 ≤ xi ≤ 109). It's guaranteed that there is at least one query of the third type.

Note, that the integer 0 will always be present in the set A.

Output

For each query of the type '?' print one integer — the maximum value of bitwise exclusive OR (XOR) of integer xi and some integer from the multiset A.

Example
input
10
+ 8
+ 9
+ 11
+ 6
+ 1
? 3
- 8
? 3
? 8
? 11
output
11
10
14
13
Note

After first five operations multiset A contains integers 089116 and 1.

The answer for the sixth query is integer  — maximum among integers  and .

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 4000005;
int a[N][3],sum[N];
int sz;
void Init()
{
    memset(a,0,sizeof(a));
    memset(sum,0,sizeof(sum));
    sz = 1;
}

void Insert(int x)
{
    int num[35];
    memset(num,0,sizeof(num));
    int cnt = 0;
    while(x)
    {
        num[cnt++] = x % 2;
        x /= 2;
    }
    int u = 0,n = 34;
    for(int i = n;i >= 0;i--)
    {
        if(!a[u][num[i]])
            a[u][num[i]] = sz++;
        u = a[u][num[i]];
        sum[u]++;
    }
}

void Delete(int x)
{
    int num[35];
    memset(num,0,sizeof(num));
    int cnt = 0;
    while(x)
    {
        num[cnt++] = x % 2;
        x /= 2;
    }
    int u = 0,n = 34;
    for(int i = n;i >= 0;i--)
    {
        int v = a[u][num[i]];
        sum[v]--;
        if(!sum[v])
            a[u][num[i]] = 0;
        u = v;
    }
}

int Query(int y)
{
    int num[35];
    memset(num,0,sizeof(num));
    int cnt = 0;
    while(y)
    {
        num[cnt++] = y % 2;
        y /= 2;
    }
    for(int i = 0;i <= 34;i++)
        num[i]= num[i] ? 0 : 1;
    int u = 0,n = 34,v,w;
    int ans = 0;
    for(int i = n;i >= 0;i--)
    {
        if(num[i])
        {
            v = 1;
            w = 0;
        }
        else
        {
            w = 1;
            v = 0;
        }

        if(a[u][v])
        {
            u =  a[u][v];
            ans += 1 << i;
        }
        else
        {
            u = a[u][w];
            //if(!v)
                //ans += 1 << i;
        }
    }
    return ans;
}
int main()
{
    int t,x;
    cin >> t;
    char s[20];
    Init();
    Insert(0);
    for(int ca = 1;ca <= t;ca++)
    {
        scanf("%s%d",s,&x);
        if(s[0] == '+')
            Insert(x);
        else if(s[0] == '-')
            Delete(x);
        else
            printf("%d\n",Query(x));
    }
    return 0;
}

感觉这样的代码有点丑陋,但是原理应该一样,弄熟了回来改


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值