HDU-1548 A strange lift(最短路[Spfa || BFS])

28 篇文章 0 订阅
21 篇文章 0 订阅

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5 3 3 1 2 5 0
 

Sample Output
  
  
3

第一眼看就知道应该要搜索,要不是放在最短路专题,还真想不到用图论做,简单题,刚好练习一下Spfa(看到Spfa时间效率不是很稳定,还是多用Dijkstra的好)

BFS占用内存少,运行快,代码少,如果是无权图还是用BFS写更好


BFS:

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

struct Node {
    int num,step;
    Node(int nn=0,int ss=0) {
        num=nn,step=ss;
    }
}u;
const int INF=0x3f3f3f3f;
int k[205];
int i,n,s,e,t,ans;
bool vis[205];

void BFS() {
    queue<Node> q;
    q.push(Node(s,0));
    vis[s]=true;
    while(!q.empty()) {
        u=q.front();
        if(u.num==e) {
            ans=u.step;
            return ;
        }
        q.pop();
        if((t=u.num+k[u.num])<=n&&!vis[t]) {
            vis[t]=true;
            q.push(Node(t,u.step+1));
        }
        if((t=u.num-k[u.num])>0&&!vis[t]) {
            vis[t]=true;
            q.push(Node(t,u.step+1));
        }
    }
}

int main() {
    while(scanf("%d",&n),n) {
        scanf("%d%d",&s,&e);
        for(i=1;i<=n;++i)
            scanf("%d",k+i);
        memset(vis,false,sizeof(vis));
        ans=INF;
        BFS();
        printf("%d\n",ans==INF?-1:ans);
    }
    return 0;
}




Spfa:

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int INF=0x3f3f3f3f;
int k[205],w[205][205],dis[205];
int i,n,s,e,t,u,tmp;
bool vis[205];

void Spfa() {
    queue<int> q;
    q.push(s);
    dis[s]=0;
    vis[s]=true;
    while(!q.empty()) {
        u=q.front();
        q.pop();
        vis[u]=false;
        for(i=1;i<=n;++i)
            if((tmp=dis[u]+w[u][i])<dis[i]&&!vis[i]) {
                dis[i]=tmp;
                vis[i]=true;
                q.push(i);
            }
    }
}

int main() {
    while(scanf("%d",&n),n) {
        scanf("%d%d",&s,&e);
        for(i=1;i<=n;++i) {
            scanf("%d",k+i);
            vis[i]=false;
            dis[i]=INF;
        }
        memset(w,0x3f,sizeof(w));
        for(i=1;i<=n;++i) {
            if((tmp=i+k[i])<=n)
                w[i][tmp]=1;
            if(0<(tmp=i-k[i]))
                w[i][tmp]=1;
        }
        Spfa();
        printf("%d\n",dis[e]==INF?-1:dis[e]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值