HDU 1097 A hard puzzle

题目:

Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin. 
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise. 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30) 

Output

For each test case, you should output the a^b's last digit number. 

Sample Input

7 66
8 800

Sample Output

9
6

题意:求出a^b的最后一位数。

思路:看见题后,因为以前做题的时候有类似的题,都是找规律,我首先就用下面的代码找了一下规律

for(int i=0;i<=10;i++){
        int t=1;
        for(int j=0;j<=10;j++){
            t=t*i;
            printf("%d ",t);
        }
        printf("\n");
    }

然后找到了这个规律, 我又用计算机器验证了其它的数,好像就是这个规律。
0: 0
1: 1
2: 2 4 8 6
3: 3 9 7 1
4: 4 6
5: 5
6: 6
7: 7 9 3 1
8: 8 4 2 6
9: 9 1

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#include <map>
using namespace std;
typedef long long LL;
int main(){
   int a,b;
   while(scanf("%d%d",&a,&b)!=EOF){
        int x=a%10;
        if(x==0){
            printf("0\n");
        }
        if(x==1){
            printf("1\n");
        }
        if(x==2){
            if(b%4==1) printf("2\n");
            if(b%4==2) printf("4\n");
            if(b%4==3) printf("8\n");
            if(b%4==0) printf("6\n");
        }
        if(x==3){
            if(b%4==1) printf("3\n");
            if(b%4==2) printf("9\n");
            if(b%4==3) printf("7\n");
            if(b%4==0) printf("1\n");
        }
        if(x==4){
            if(b%2==1) printf("4\n");
            else printf("6\n");
        }
        if(x==5){
            printf("5\n");
        }
        if(x==6){
            printf("6\n");
        }
        if(x==7){
            if(b%4==1) printf("7\n");
            if(b%4==2) printf("9\n");
            if(b%4==3) printf("3\n");
            if(b%4==0) printf("1\n");
        }
        if(x==8){
            if(b%4==1) printf("8\n");
            if(b%4==2) printf("4\n");
            if(b%4==3) printf("2\n");
            if(b%4==0) printf("6\n");
        }
        if(x==9){
            if(b%2==1) printf("9\n");
            else printf("1\n");
        }
   }
}

AC之后,觉得这题应该是一道快速幂的题,就去网上想找一下快速幂的解法,结果发现大家都是用的找规律。

就找了一个快速幂的讲解的:http://blog.csdn.net/lsldd/article/details/5506933

方便以后自己复习。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值