UVA 147 Dollars 基础DP(水)

 Dollars 

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2 tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293

比较基础的Dp,浮点数存在精度问题,先转换成整数(注意强制转换+0.5)val[12]表示11种面值,d[i]表示金额i的组合方式  转移方程 d[j]=d[j]+d[j-val[i]],最小面值为5,直接递增5到30000,然后查表就ok:
 
#include<cstdio>
#include<cstring>
using namespace std;
long long d[30005];
int val[12]={10000,5000,2000,1000,500,200,100,50,20,10,5},a;
int main()
{
    double fm;
    d[0]=1;
    for(int i=0;i<11;++i)
        for(int j=val[i];j<=30000;j+=5)
            d[j]+=d[j-val[i]];
    while (scanf("%lf",&fm),a=int(fm*100+0.5))
        printf("%6.2lf%17lld\n",fm,d[a]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值