HDU-1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

[Code] 
import java.util.Scanner;

public class Main {
	public static void main(String args[]) {
		int count = 0;
		int row, n;
		Scanner cin = new Scanner(System.in);
		row = cin.nextInt();
		int array []  = new int[100002];
		while (row-- != 0) {
			n = cin.nextInt();
			for(int i=0;i<n;i++)
				array[i] = cin.nextInt();
			System.out.println("Case " + ++count + ":");
			maxSum(array,n);
			if (row != 0)
				System.out.println();
			
		}
	}
	public static void maxSum(int a[],int n) {
		int max, sum, start = 1, num = 1;
		int pre = start; // pre 最终确定的开始位置start 是每次+后的开始位置
		max = sum = a[0];// 
		for (int i = 1; i < n; i++) {
			if (sum < 0)
				{
					sum = a[i];
					start = i+1;//第次加一个数后,这个数可能被加入最后结果,也可能不被加入最后结果,所以要用一个pre 来确定最后结果
				}
			else {
					sum += a[i];
			}
			
			if (sum > max) { //每次条件符合说明位置都是更改
				max = sum;
				num = i+1;
				pre = start;// 定义最后结果
			}
		}
		System.out.println(max+" "+(pre)+" "+(num));
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值