hdu-1003 Max Sum

4 篇文章 0 订阅

Problem Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
这是一个简单的求最大子串的问题:

#include <iostream>
#include<stdio.h>

using namespace std;
int main(){

    int n;//总测试数据组数
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        int left=1,right=0,lefttemp=1;//最大子串的左边,右边,和暂定的临时左边
        int max=-999999,maxtemp=0;//子串的最大和值,暂定的临时最大和值
        int m;//数字串长度
        int temp;//获取数据的临时变量
        scanf("%d",&m);
        for(int j=1;j<=m;j++){
             scanf("%d",&temp);
             maxtemp+=temp;//加到临时最大和中
             if(max<maxtemp){//如果临时的最大和比确定的之前最大和大
                 max=maxtemp;//就将临时的最大和确定下来
                 left=lefttemp;//此时暂定的左边也确定下来
                 right=j;//右边就是当前选定的右边
             }
             if(maxtemp<0){//如果临时的最大和是负数,之前的数据就不一定能加入到最大子串中了,可能会在后面重新找最大字串(需要用到临时的左边)
                 lefttemp=j+1;//让临时的左边从之后不小于0的数字重新开始算
                 maxtemp=0;//重新开始算,让临时最大和也重新从0开始算
             }
        } 
        if(i!=n)printf("Case %d:\n%d %d %d\n\n",i,max,left,right);
        else printf("Case %d:\n%d %d %d\n",i,max,left,right);    
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值