POJ Heavy Cargo 最短路径 Dijkstra 变形

 

Heavy Cargo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1924 Accepted: 1065

Description

Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.

Output

For each test case, print three lines:
  • a line saying "Scenario #x" where x is the number of the test case
  • a line saying "y tons" where y is the maximum possible load
  • a blank line

Sample Input

4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0

Sample Output

Scenario #1
80 tons
 
Scenario #2
170 tons

 

题意:有一个卡车公司能生产非常大的卡车,卡车打的足以装下任何大小和重量的货物;现在 要用这卡车 运送货物, 从城市A运送到城市B,城市与城市之间的道路构成一个 无向图, 道路有最大的承受重量,请选择 运送的路径 输出 能卡车 最多可以装载多少货物;

思路:应该是网络流的题目,不过 用Dijkstra也可以解, 利用Dijkstra算法 求出每条路径的最小装载,然后在这些最小装载中 找到最大的一个;

#include <iostream>
using namespace std;
char name[201][50];
int w[201][201],dis[201];
int sum,n,r;
int getnum(char t[])
{
	for(int i=0; i<=sum; i++)
	if(!strcmp(name[i], t))
		return i;
	sum++;
	strcpy(name[sum], t);
	return sum;
}
int Dijkstra(int s, int e)
{
	int i,j,t,minw;
	bool flag[201]={0};
	for(i=0; i<n; i++)
		dis[i] = w[s][i];
	dis[s]=0; flag[s]=true;
	for(i=0; i<n; i++)
	{
		minw = dis[e]; t = s;
		for(j=0; j<n; j++)
		if(dis[j]>minw && !flag[j])
		{
			t = j;
			minw = dis[j];
		}
		if(flag[t]) return dis[e];
		flag[t] = true;
		for(j=0; j<n; j++)
		if(!flag[j] && w[t][j]>-1)
		{
			minw = dis[t]>w[t][j]?w[t][j]:dis[t];
			dis[j] = dis[j]<minw?minw:dis[j];
		}
	}
	return dis[e];
}
int main()
{
	int i,weight,s,e,Case=0;
	char a[50],b[50];
	while(scanf("%d %d%*c", &n, &r),n+r)
	{
		memset(w,-1,sizeof(w));
		memset(name,'\0',sizeof(name));
		sum=-1;
		for(i=0; i<r; i++)
		{
			scanf("%s %s %d", &a, &b, &weight);
			s = getnum(a); e = getnum(b);
			w[s][e]=w[e][s]=weight;
		}
		scanf("%s %s", &a, &b);
		s = getnum(a); e = getnum(b);
		printf("Scenario #%d\n%d tons\n\n",++Case, Dijkstra(s,e));
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值