POJ 2263 Heavy Cargo(Dijkstra算法)

13 篇文章 0 订阅
9 篇文章 0 订阅
Heavy Cargo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1787 Accepted: 1012

Description

Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.

Output

For each test case, print three lines:
  • a line saying "Scenario #x" where x is the number of the test case
  • a line saying "y tons" where y is the maximum possible load
  • a blank line

Sample Input

4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0

Sample Output

Scenario #1
80 tons
 
Scenario #2
170 tons

Source

//Dijkstra算法

//每次要找出最大装载的车道,然后连向其他的city[j],这个最大装载比到city【j】后面的装载比行比较,得出小的装载,再和原来可以直接到达的city[j]的

//装载进行比较,得出较大就是city[j]的最大最终装载

#pragma warning(disable:4768)
#include<iostream>
#include<map>
#include<string>
using namespace std;

#define N 202

int g[N][N], dist[N];
bool visited[N];
map<string, int>m;

int min(int a, int b) {
    return a<b? a:b;
}

int max(int a, int b) {
    return a>b? a:b;
}
void dijkstra(int v, int n)
{
    int i, j;
    for(i = 0; i <= n; i++) {
        dist[i] = g[v][i];
        visited[i] = false;
    }
    visited[v] = true; dist[v] = 0;
    for(i = 1; i < n; i++) {
        int tmp = 0;
        int k = v;
        for(j = 1; j <= n; j++) {
            if((!visited[j]) && (tmp < dist[j])) {
                tmp = dist[j];
                k = j;
            }
        }
        visited[k] = true;
        for(j = 1; j <= n; j++) {
            if((!visited[j]) && (g[k][j] > -1)) {
                dist[j] = max(min(dist[k], g[k][j]), dist[j]);
            }
        }
    }
}    

int main()
{
    int i, j, n, r, x, cnt, C= 0;
    char s1[33], s2[33];
    while(true) {
        cin>>n>>r;
        if(n == 0 && r == 0) break;
        for(i = 0; i <= n; i++)
            for(j = 0; j <= n; j++)
                g[i][j] = -1;
        m.clear();
        for(i = 0, cnt = 1; i < r; i++) {
            cin>>s1>>s2>>x;
            if(!m[s1]) m[s1] = (cnt++);
            if(!m[s2]) m[s2] = (cnt++);
            g[m[s1]][m[s2]] = x;
            g[m[s2]][m[s1]] = x;
        }
        cin>>s1>>s2;
        dijkstra(m[s1], n);
        printf("Scenario #%d\n", ++C);
        printf("%d tons\n", dist[m[s2]]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值