uva 10391 Compound Words(stl map)

942 篇文章 2 订阅
232 篇文章 0 订阅

Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
题目大意:给出一些字符串,如果当前字符串可以由给出的如意两个字符串组成,输出。

解题思路:借助stl中的map,对出现的字符串进行标记,对于每个字符串呢,将字符串分层两段,判断分成的两段是否出现(两段长度要遍历一遍)。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
#include <string>
using namespace std;

const int N = 120005;
const int M = 30;
map<string, int> vec;

int main() {
    int n = 0;
    char str[N][M];

    while (gets(str[n]) != NULL) {
	vec[str[n++]] = 1;
    }

    for (int i = 0; i < n; i++) {
	int len = strlen(str[i]);
	for (int j = 0; j < len - 1; j++) {
	    char p[M], q[M];
	    strncpy(p, str[i], j);
	    p[j] = '\0';
	    for (int k = j; k < len; k++) 
		q[k - j] = str[i][k];
	    q[len - j] = '\0';
	    if (vec[p] + vec[q] == 2) {
		printf("%s\n", str[i]);
		break;
	    }
	}
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值