UVA 10391 Compound Words

Description

You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
 

 

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
 

 

Output

Your output should contain all the compound words, one per line, in alphabetical order.
 

 

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
 

 

Sample Output

alien
newborn

 

 

 

解题思路:将单词保存在set中,遍历set中的元素,将其中的每一个单词拆分成两个单词,对于拆分出来的单词看是否在set中出现过,若两个都出现过,那么该单词为复合词

 

遇到的问题:最开始我用vector来存放string,但是结果为TLE,当把容器换为set以后就AC了。猜想原因有二:一、OJ上测试时输入了重复的数据,因此采用set的效率更高。但是实际上用set程序运行时间为70ms,而vector运行时间大于3000ms,时间差距过大,因此可能不是重复输入数据的原因。二、在用find的时候,vector用的是stl库中的函数,调用形式为find(dic.begin(),dic.end(),temp);而用set的时候使用的set的函数,调用形式为dic.find(temp),因此猜想可能是前者的效率低,直接导致了TLE,该猜想未经验证

 

 

#include<iostream>  
#include<cstdio>  
#include<stack>  
#include<string>
#include<vector>
#include<sstream>
#include<math.h>
#include<map>
#include<string>
#include<set>
#include <algorithm>
using namespace std;


int main() {
	
	string word;
	string temp;
	string remain;
	string a;
	set<string> dic;
	set<string>::iterator it;


	while (cin>>word)
	{			
		dic.insert(word);
	}

	for (it = dic.begin(); it != dic.end(); it++)
	{
		for (int j = 1; j < (*it).size()+1; j++)
		{
			temp = (*it).substr(0, j);
			remain = (*it).substr(j, ((*it)).size()-j);
			set<string>::iterator result1 = dic.find(temp);
			set<string>::iterator result2 = dic.find(remain);
			if (result1 != dic.end()&& result2 != dic.end() )
			{
				cout << (*it) << endl;
				break;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值