A Simple Problem with Integers POJ - 3468 [成段更新,lazy]

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 117033 Accepted: 36387
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... ,AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

代码还是源自: 博客
还是附上原博主代码风格:
  • lson和rson分辨表示结点的左儿子和右儿子,由于每次传参数的时候都固定是这几个变量,所以可以用预定于比较方便的表示
  • 以前的写法是另外开两个个数组记录每个结点所表示的区间,其实这个区间不必保存,一边算一边传下去就行,只需要写函数的时候多两个参数,结合lson和rson的预定义可以很方便
  • PushUP(int rt)是把当前结点的信息更新到父结点
  • PushDown(int rt)是把当前结点的信息更新给儿子结点
  • rt表示当前子树的根(root),也就是当前所在的结点



这题是两三天前做的,当时不太懂那个区间成段更新时 lazy 的思想。
其实lazy就是在更新的时候只更新到你所选取的区间,不继续向下(向子区间)更新,但是保留住当前需要继续加的值。
在下次需要更新时再更新。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#define inf 0x3f3f3f
#define ms(x) memset(x, 0, sizeof(x))
using namespace std;
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define ll long long
const int N = 100007;
ll add[N<<2];
ll sum[N<<2];
void PushUp(int rt)
{
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void PushDown(int rt, int m)
{
    if(add[rt])                                 //就是这里 也可能算上了之前应该更新的
    {
        add[rt<<1] += add[rt];
        add[rt<<1|1] += add[rt];
        sum[rt<<1] +=add[rt] * (m - (m>>1));
        sum[rt<<1|1] += add[rt] * (m>>1);
        add[rt] = 0;
    }
}
void build(int l, int r, int rt)
{
    add[rt] = 0;
    if(l == r)
    {
        scanf("%lld", &sum[rt]);
        return ;
    }
    int m = (l+r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void Update(int x, int y, int c, int l, int r, int rt)
{
    if(x<=l&&r<=y)
    {
        add[rt] += c;
        sum[rt] +=(ll) c * (r-l+1);              //为节省时间
        return ;                                 //区间更新到你所要求的地方就返回,不再向下更新。如果下次你所要求的区间更小,那么会继续更新
}
    PushDown(rt, r-l+1);
    int m = (l + r)>>1;
    if(x <= m) Update(x, y, c, lson);
    if(m <  y) Update(x,y,c,rson);
    PushUp(rt);
}
ll query(int x, int y, int l, int r, int rt)
{
    if(x<=l && r<=y)
    {
        return sum[rt];
    }
    PushDown(rt, r-l+1);
    int m = (l + r)>>1;
    ll ret = 0;
    if(x <= m)    ret += query(x, y, lson);
    if(m < y)   ret += query(x, y, rson);
    return ret;
}
int main()
{
    int n, q;
    scanf("%d%d", &n, &q);
    build(1, n, 1);
    while(q--)
    {
        char s[2];
        int a, b, c;
        scanf("%s",s);
        if(s[0]=='Q')
        {
            scanf("%d%d",&a,&b);
            printf("%lld\n", query(a, b, 1, n, 1));
        }
        else
        {
            scanf("%d%d%d", &a, &b, &c);
            Update(a, b, c, 1, n, 1);
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值