POJ 2081 Recaman's Sequence 解题报告

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658


/**
 题目大意:如果am−1 − m为正数,且未在序列中出现则am = am−1 − m,否则am = am−1 + m
*/

#include<iostream>
#include<cstdio>

using namespace std;

#define N 500000

long a[N + 5] = {0};
bool flag[10*N] = {true, false};

int main()
{
	int i;
	for(i = 1; i <= N; i++) {
		if(a[i-1] - i > 0 && !flag[a[i-1] - i]) {
			a[i] = a[i-1] - i;
			flag[a[i-1] - i] = true;
		} else {
			a[i] = a[i-1] + i;
			flag[a[i-1] + i] = true;
		}
	}
	int n;
	while(scanf("%ld", &n) && n != -1) {
		printf("%d\n", a[n]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值