九度OJ 题目1446:Head of a Gang

一.题目描述 
One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.
输入:
For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.
输出:
For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.
样例输入:

 8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
样例输出:

2
AAA 3
GGG 3
0

二.题目分析

本题中采用DFS先搜索出相连的人,然后通过gang的两个判断条件,一是总时间数超过K,二是总人数大于2来判断是否是一个gang。

三.代码

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX 1001
typedef struct Rec
{
    char str1[4],str2[4];
    int time;
}Relation;

typedef struct Ga
{
    char head[4];
    int num;
}Gang;

Relation map[MAX];
Gang gang[MAX];
int N,K,cn,visit[MAX],count[MAX];
int Com(int index,char *str)
{
    if(strcmp(str,map[index].str1)!=0&&strcmp(str,map[index].str2)!=0)
        return 0;
    return 1;
}
void DFS(int i)
{
    int j;
    visit[i]=1;
    count[cn]=i;
    cn++;
    for(j=0;j<N;j++)
    {
        if(!visit[j]&&(Com(i,map[j].str1)||Com(i,map[j].str2)))
            DFS(j);
    }
}
int cmp(const void *a,const void *b)
{
    return strcmp((*(Gang *)a).head,(*(Gang *)b).head);
}
int main()
{
    int i,j,k1,k2,k3,w,n,nu,max,all,b[27][27][27];
    char x,y,z,str[4];

    freopen("1446.txt","r",stdin);

    while(scanf("%d%d",&N,&K)!=EOF)
    {
        for(i=0;i<N;i++)
            scanf("%s%s%d",map[i].str1,map[i].str2,&map[i].time);

        for(i=0;i<N;i++)
            visit[i]=0;

        nu=0;
        for(i=0;i<N;i++)
        {
            if(!visit[i])
            {
                cn=0;
                //先找出所有的连通分量,将标号保存在count[]中
                DFS(i);
                all=0;
                n=0;
                max=-1;
                for(k1=0;k1<26;k1++)
                        for(k2=0;k2<26;k2++)
                            for(k3=0;k3<26;k3++)
                                b[k1][k2][k3]=0;

                //统计每一个连通分量的时间总数,并将每个人根据名字映射到b[][][]中,其值为时间。
                for(j=0;j<cn;j++)
                {
                    all +=map[count[j]].time;
                    b[map[count[j]].str1[0]-'A'][map[count[j]].str1[1]-'A'][map[count[j]].str1[2]-'A']+=map[count[j]].time;
                    b[map[count[j]].str2[0]-'A'][map[count[j]].str2[1]-'A'][map[count[j]].str2[2]-'A']+=map[count[j]].time;
                }

                //若总时间满足要求,继续判断每个连通分量里的人的个数是否大于2
                if(all>K)
                {
                        for(k1=0;k1<26;k1++)
                        {
                             for(k2=0;k2<26;k2++)
                             {
                                  for(k3=0;k3<26;k3++)
                                  {
                                      if(b[k1][k2][k3]>0)   //统计人的个数
                                        n++;
                                      if(b[k1][k2][k3]>max)  //记录时间最多的人,将名字保存在str中
                                      {
                                          max=b[k1][k2][k3];
                                          str[0]=k1+'A';
                                          str[1]=k2+'A';
                                          str[2]=k3+'A';
                                          str[3]='\0';
                                      }
                                  }
                             }
                        }
                        //如果人数大于2,则出现一个gang ,保存起来
                        if(n>2)
                        {
                            strcpy(gang[nu].head,str);
                            gang[nu].num=n;
                            nu++;
                        }
                }
            }
        }

        //统计完所有的gang ,则按照名字字典序排序后输出
        qsort(gang,nu,sizeof(gang[0]),cmp);
        printf("%d\n",nu);
        for(i=0;i<nu;i++)
            printf("%s %d\n",gang[i].head,gang[i].num);

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值