HDU2522:A simple problem

Problem Description
Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.
 

Input
第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).
 

Output
输出1/n. (是循环小数的,只输出第一个循环节).
 

Sample Input
  
  
4 2 3 7 168
 

Sample Output
  
  
0.5 0.3 0.142857 0.005952380


 

其实这道题咋看没啥思路,自己在演草纸上写出这个过程就能发现规律了,我们知道,出发就是一个整除和取余的问题,只要取余的数重复出现了,那么以后出现的肯定就是循环节了

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int hash[100005];

void div(int n)
{
    int l = 1;
    hash[1] = 1;
    while(l)
    {
        l*=10;
        printf("%d",l/n);
        l%=n;
        if(hash[l])
        break;
        hash[l] = 1;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        memset(hash,0,sizeof(hash));
        scanf("%d",&n);
        if(n<0)
        {
            printf("-");
            n = -n;
        }
        if(n == 1)
        {
            printf("1\n");
            continue;
        }
        printf("0.");
        div(n);
        printf("\n");
    }

    return 0;
}
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int hash[100005];

void div(int n)
{
    int l = 1;
    hash[1] = 1;
    while(l)
    {
        l*=10;
        printf("%d",l/n);
        l%=n;
        if(hash[l])
        break;
        hash[l] = 1;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        memset(hash,0,sizeof(hash));
        scanf("%d",&n);
        if(n<0)
        {
            printf("-");
            n = -n;
        }
        if(n == 1)
        {
            printf("1\n");
            continue;
        }
        printf("0.");
        div(n);
        printf("\n");
    }

    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值