ZOJ3671:Japanese Mahjong III

Mahjong is a game of skill, strategy and calculation and involves a certain degree of chance. In this problem, we concentrate on Japanese Mahjong, a variation of mahjong. For brief, all of the word mahjong mentioned following refer to Japanese Mahjong.

Japanese mahjong is usually played with 136 tiles, which can be organized into several categories:

  • Suited tiles. All suited tiles are of a rank and a suit.There are three suits of tiles, with ranks ranging from one to nine. There are four tiles of each rank and suit combination, thus there are 36 tiles in a suit, and 108 suited tiles in total.
    • The circle suit
    • The bamboo suit
    • The character suit
  • Honor tiles. Honor Tiles are tiles that do not have a rank or suit. They are divided into two categories. There are four types of Wind tiles and three types of Dragon tiles, with four of each type of honor tile. Thus, there are 16 wind tiles and 12 Dragon tiles for 28 honor tiles.
    • Wind tiles. The Wind tiles consist of four kinds of tile: EastSouthWest, and North.
    • Dragon tiles. The Dragon titles consist of three types of tile: RedGreenWhite.

In this problem, we introduce two abnormal kinds of winning hand different from the normal winning hand, which consist of four melds and one eyes.

  1. Seven Pairs: the hand consists of seven different pairs. No two pairs are the same. For example:
  2. Thirteen Orphans: the hand consists of thirteen kinds of tiles: Circle One, Circle Nine, Bamboo One, Bamboo Nine, Character One, Character Nine, East, South, West, North, Red, Green and White. Only one kind of them are two tiles, while the others are all only one tile. For example: 

Now, given a hand with 14 tiles, can you answer this hand is which kind of abnormal kind of winning hand?

Input

There are multiple cases. Each case consists of 28 characters in one line, describing 14 tiles. The manner for describing each type of tile is:

  • Two characters stand for one tile.
  • For Suited tiles, the first is a integer ranged from one to nine, the tile's rank, and the second is a character: 'p' for the circle suit, 's' for the bamboo suit, and 'm' for the character suit.
  • For Honor tiles, the first is a integer: from one to seven stands for EastSouthWestNorthWhiteGreen, and Red respectively. The second one is always 'z'.
We promise that the input is a legal hand, which means there isn't another type of tiles described above or there are more than four same tiles.
Output

For each case, if the hand is Seven Pairs, output "Seven Pairs". If the hand is Thirteen Orphans, output "Thirteen Orphans". If the hand is neither Seven Pairs nor Thirteen Orphans, output "Neither!".

Sample Input
1z1z2z2z3z3z4z4z5z5z6z6z7z7z
1s9s1m9m1p9p1z2z3z4z5z6z7z7z
1s9s1m9m1p9p1z2z3z4z5z6z7z7p
Sample Output
Seven Pairs
Thirteen Orphans
Neither!




判断是七对还是十三幺,七对必须都不同


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[4][10],len;
char str[50];

int main()
{
    int i,j,flag;
    while(~scanf("%s",str))
    {
        len = strlen(str);
        memset(a,0,sizeof(a));
        for(i = 0; i<len; i+=2)
        {
            if(str[i+1] == 'p')
                a[0][str[i]-'0']++;
            else if(str[i+1] == 's')
                a[1][str[i]-'0']++;
            else if(str[i+1] == 'm')
                a[2][str[i]-'0']++;
            else
                a[3][str[i]-'0']++;
        }
        flag = 1;
        for(i = 0; i<4; i++)
        {
            for(j = 1; j<10; j++)
            {
                if(a[i][j] && a[i][j]!=2)
                {
                    flag = 0;
                    break;
                }
            }
            if(!flag)
                break;
        }
        if(flag)
        {
            printf("Seven Pairs\n");
            continue;
        }
        if(a[0][1] && a[0][9] && a[1][1] && a[1][9] && a[2][1] && a[2][9] && a[3][1] && a[3][2] && a[3][3] && a[3][4] && a[3][5] && a[3][6] && a[3][7])
        {
            if(a[0][1] == 2 || a[0][9] == 2 || a[1][1] == 2 || a[1][9] == 2 || a[2][1] == 2 || a[2][9] == 2 || a[3][1]==2 || a[3][2]==2 || a[3][3]==2 || a[3][4]==2 || a[3][5]==2 || a[3][6]==2 || a[3][7]==2)
            {
                printf("Thirteen Orphans\n");
                continue;
            }
        }
        printf("Neither!\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值