POJ1975:Median Weight Bead(FLOYD)

Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: 
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight. 

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5. 
1.	Bead 2 is heavier than Bead 1.

2.	Bead 4 is heavier than Bead 3.

3.	Bead 5 is heavier than Bead 1.

4.	Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads. 

Write a program to count the number of beads which cannot have the median weight. 

Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. 

Output

There should be one line per test case. Print the number of beads which can never have the medium weight.

Sample Input

1
5 4
2 1
4 3
5 1
4 2

Sample Output

2

Source


输入n,m
有n个数,m个约束
每个约束输入,x,y,代表x重要y
求这n个数有几个是必定不能出现在中点的
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define Len 200005
#define mod 19999997
const int INF = 0x3f3f3f3f;
#define exp 1e-6

int t,n,m,a[105][105];

int main()
{
    int i,j,k,x,y;
    scanf("%d",&t);
    w(t--)
    {
        scanf("%d%d",&n,&m);
        mem(a,0);
        w(m--)
        {
            scanf("%d%d",&x,&y);
            a[x][y] = 1;
            a[y][x] = -1;
        }
        up(k,1,n)
        {
            up(i,1,n)
            {
                up(j,1,n)
                {
                    if(a[i][k]==1 && a[k][j]==1)
                    a[i][j] = 1;
                    if(a[i][k]==-1 && a[k][j]==-1)
                    a[i][j] = -1;
                }
            }
        }
        int l,r,ans = 0;
        up(i,1,n)
        {
            l = r = 0;
            up(j,1,n)
            {
                if(a[i][j]==1)
                l++;
                else if(a[i][j]==-1)
                r++;
            }
            if(l>=(n+1)/2)
            ans++;
            else if(r>=(n+1)/2)
            ans++;
        }
        printf("%d\n",ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值