hdu 1829 A Bug's Life(分组并查集)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11242    Accepted Submission(s): 3664


Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint

Huge input,scanf is recommended.

题意: 给出昆虫的数量n和m个关系,输入a b即为a喜欢b,假设虫子只喜欢异性,问根据这一些列行为是否能发现同性恋的虫子  思路: 并查集的使用和理解,,思路好难想,下边是理解大神代码后的注释  2015,7,22

#include<stdio.h>
#include<string.h>
struct node{
	int from;//父节点 即为自己的性别 
	int conflict;//用来存对象的性别 
}f[2100];
int find(int x)
{
	if(f[x].from!=x)
		x=find(f[x].from);
	return x;
}
void merge(int a,int b)
{
	int x=find(a);
	int y=find(b);
	if(x!=y)
		f[x].from=y;
}
int main()
{
	int t,n,m,flag,Case=1,i,a,b;
	scanf("%d",&t);
	while(t--){
		flag=0;
		memset(f,0,sizeof(f));
		scanf("%d%d",&n,&m);
		for(i=0;i<=n;i++)
		{
			f[i].from=i;//父节点都初始化为自己 
			f[i].conflict=0;//开始初始化都没有对象 
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);//给出两个相互为对象 
			int x=find(a);
			int y=find(b);
			if(x==y) flag=1;//他们的父节点一样,那就是他们在一个集合里,就属于同性恋 
			if(f[a].conflict!=0)//如果a有对象 
				merge(b,f[a].conflict);//就把b拉到a对象的那个性别集合中 
			if(f[b].conflict!=0)//如果b有对象 
				merge(a,f[b].conflict);//把a拉到b对象的那个性别集合中 
			f[a].conflict=b;//把a的对象设置为b 
			f[b].conflict=a;//把b的对象设置为a 
		}
		if(flag==1)
			printf("Scenario #%d:\nSuspicious bugs found!\n",Case++);
		else printf("Scenario #%d:\nNo suspicious bugs found!\n",Case++);
		printf("\n");
	}	
	return 0;
} 
//在贴个比较好懂的代码,思想差不多。 
#include<stdio.h>  
int mark[2020], a[2020];  
int find(int x)  
{  
    if(x != mark[x])  
    {  
        mark[x] = find(mark[x]);  
    }  
    return mark[x];  
}  
void merge(int x, int y)  
 {  
    x = find(x);  
    y = find(y);  
    if(x != y)  
    {  
        mark[x] = y;  
    }   
}  
int main()  
{  
    int i, j, k, m, n, T, x, y, ok, cas = 1;  
    scanf("%d", &T);  
    while(T--)  
    {  
        scanf("%d%d", &n, &m);  
        ok = 0;  
        for(i = 0; i <= n+1; i++)  
        {  
            mark[i] = i;  
            a[i] = -1;  
        }  
        for(i = 0; i < m; i++)  
        {  
            scanf("%d%d", &x, &y);  
            if(ok)  
            continue;  
            if(a[x] != -1)//x有对象   
            {  
                if(a[y] != -1)// y有对象   
                {  
                    if(find(x) == find(y))//若x和y在一个性别集合里   
                    ok = 1;      //同性。。   
                    merge(x,a[y]);//否则令彼此的对象都归为和彼此一样的性别集合内   
                    merge(y,a[x]);  
                }  
                else//y没对象   
                {  
                    a[y] = x;//设定y的对象   
                    merge(y,a[x]);//令y和x的对象在一个性别集合里   
                }  
            }   
            else//x没对象   
            {  
                if(a[y] != -1)//y有对象   
                {  
                    a[x] = y;//设定x的对象   
                    merge(x, a[y]);//令x和y的对象在一个性别集合里   
                }  
                else  
                {  
                    a[x] = y;//彼此设定对象   
                    a[y] = x;  
                }  
            }  
        }  
        if(ok)  
        printf("Scenario #%d:\nSuspicious bugs found!\n", cas++);  
        else  
        printf("Scenario #%d:\nNo suspicious bugs found!\n", cas++);   
        printf("\n");   
    }  
    return 0;  
}   


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值