HDU_1829 A Bug's Life(并查集)

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 
题解:
题目的意思是给出很多个交配组合,看看是否会出现同性交配的情况。根据题目给出的信息,我们只能得到两个bug之间的相对性别关系,不能将他们的性别的关系确定下来。所以想到我们可以利用并查集来维护每个生物一个相对的性别关系,在记录Father的同时,要用Sex数组来表示与父节点的性别关系。所以整个过程中同一棵树的深度不会超过2,当两颗树合并时,利用性别的相对关系在更新Father的同时,将性别关系也同时更新。
这是一道并查集的变形,关键在于想清楚如何表示相对关系,利用并查集的性质进行递归更新,感觉并查集的重点就是如何维护好一棵树,嗯,就是这样。
代码实现:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;

const int MAX = 2010;

int T;
int N,M;
bool flag;
int Sex[MAX];
int Father[MAX];
int Find(int x);
void Union(int x,int y);
int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&T);
    for( int t = 1; t <= T; t++ ){
        flag = true;
        scanf("%d%d",&N,&M);
        for( int i = 1; i <= N; i++ ){
            Father[i] = i;
            Sex[i] = 0;
        }
        int a,b;
        for( int i = 0; i < M; i++ ){
            scanf("%d%d",&a,&b);
            if( !flag ){
                continue;
            }
            Union(a,b);
        }
        printf("Scenario #%d:\n",t);
        if( flag ){
            printf("No suspicious bugs found!\n");
        }
        else{
            printf("Suspicious bugs found!\n");
        }
        printf("\n");
    }
    return 0;
}

int Find(int x){
    if( x == Father[x] ){
        return x;
    }
    //注意这里的顺序,先调用Find函数把父节
    //点之前的节点维护好,然后再去维护当前节点
    int tmp = Find(Father[x]);
    Sex[x] = (Sex[x]+Sex[Father[x]])%2;
    return Father[x] = tmp;
}

void Union(int x,int y){
    int a,b;
    a = Find(x);
    b = Find(y);
    if( a == b ){
        if( Sex[x] == Sex[y] ){
            flag = false;
            return ;
        }
    }
    else{
        Father[a] = b;
        Sex[a] = (Sex[y]+Sex[x]+1)%2;
    }
    return ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值