poj2479Maximum sum【dp】

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37038 Accepted: 11555

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

跟poj2593一样~

#include<cstring>
#include<cstdio>
const int M=5e4+10;
int a[M], b[M], c[M];
int main(){
	
	int t;
	scanf("%d", &t);
	while(t--)
	{
		int i,j,k,m,n;
		scanf("%d", &n);
		k = 0;
		m = -10001;
		for(i = 0; i < n; i++)
		{
			scanf("%d", &a[i]);
			k += a[i];
			if(k > m)
				m = k;
			if(k < 0)
				k = 0;
			b[i] = m;		
		}
		k = 0;
		m = -10001;
		for(i = n-1; i>=0; i--)
		{
			k+=a[i];
			if(k > m)
				m = k;
			if(k < 0)
				k = 0;
			c[i] = m;		
		}
		int mx = b[0]+c[1];
		for(i = 0; i<n-1;i++)
		{
			if(mx < b[i]+c[i+1])
				mx = b[i]+c[i+1];
		}
		printf("%d\n", mx);
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值