poj 2479 dp Maximum sum求两段连续不重叠子段的最大和

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36996 Accepted: 11535

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.
#include <iostream>
#include<cstdio>
using namespace std;
int dp[100001];
int a[100001];
#define INF -99999999

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
       scanf("%d",&n);
        int sum=0,ans;
        int temp=INF;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            //从左向右求最大字段和
            sum+=a[i];
            if(temp<sum)
                temp=sum;
            dp[i]=temp;
            if(sum<0)
                sum=0;
        }
        //从右行左找右边字段与左边字段的最大值
        temp=ans=INF;
        sum=0;
        for(int i=n; i>1; i--)
        {
            sum+=a[i];
            if(temp<sum)
                temp=sum;
            if(ans<dp[i-1]+temp)
                ans=dp[i-1]+temp;
            if(sum<0)
                sum=0;
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值