poj 2479 Maximum sum 两段不相交最大子段和

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31315 Accepted: 9595

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

[Submit]   [Go Back]   [Status]   [Discuss]


题意很简单,分别从左和从右求最大子段和 然后枚举中间点即可  之和就是最大sum


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int INF=1e9;

int a[55555];
int dp[55555];
int L[55555],R[55555];

int solve(int a[],int n)
{
    int i;
    dp[0]=-INF;
    for(i=1;i<=n;i++)
        dp[i]=max(dp[i-1]+a[i],a[i]);
    L[0]=-INF;
    for(i=1;i<=n;i++)
        L[i]=max(dp[i],L[i-1]);
    dp[n+1]=-INF;
    for(i=n;i>=1;i--)
        dp[i]=max(dp[i+1]+a[i],a[i]);
    R[n+1]=-INF;
    for(i=n;i>=1;i--)
        R[i]=max(dp[i],R[i+1]);
    int ans=-INF;
    for(i=1;i<=n;i++)
        ans=max(ans,L[i]+R[i+1]);
    return ans;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        int i;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        printf("%d\n",solve(a,n));
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值