Poj 1017 Packets【贪心+细节】

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49569 Accepted: 16769

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 


题意:

给出1*1,2*2.....6*6 的方块(高度不考虑),全部放入6*6的箱子中,问最少需要多少个箱子。


题解:

题目给出不需要考虑高度的情况了,然后就是面积,然后就比较复杂了.....

1,先考虑大的,对于4*4,5*5,6*6 的方块,必定每个占用一个箱子,对于3*3的,每四个正好占用一个箱子

2,考虑放2*2的方块,统计出之前用过的箱子有多少位置能放2*2的方块,注意方块数量可能不够

3,考虑放1*1的方块,也就是箱子中剩下的所有空间了!放入1*1的方块(注意点同上一步)

4,剩余的1*1 和2*2 的直接统计面积,看额外至少需要多少个箱子

详细解释见代码。


个人本来想找个非常好的方法直接进行模拟,.结果失败了......

后来实在没办法,还是最直接的贪心枚举六种的情况吧......

竟然还是WA!!后来才发现,原来是跳出主程序的语句没控制好...........


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
ll tab[]={0,5,3,1};//tab[i]表示放i个3*3的,还能放多少2*2的 
ll slove(ll x[])
{
	ll num3=ceil(x[3]/4.0);//3*3的必须使用的盒子数量 
	ll ans=x[6]+x[5]+x[4]+num3;//不包括1*1和2*2 时必须使用的盒子的数量 
	ll num2=5*x[4]+tab[x[3]%4];//统计能放2*2的个数
	num2=min(num2,x[2]); //计算能使用的2*2的方块最大数量
	x[2]-=num2;//2*2的方格使用掉
	ll rest=36*ans-x[6]*36-x[5]*25-x[4]*16-x[3]*9-num2*4;//剩余位置
	rest=min(rest,x[1]);//能使用1*1的最大数量 
	x[1]-=rest;//使用1*1的方块 
	rest=x[2]*4+x[1];//看是否有剩余,有的话,单独找个大箱子 
	return ans+ceil(rest/36.0);
}
int main()
{
	ll x[10];
	//freopen("shuju.txt ","r",stdin);
	while(~scanf("%lld",&x[1]))
	{
		int kase=x[1];//坑了我一次WA,自己思维不够严谨
		for(ll i=2;i<=6;++i)
		{
			scanf("%lld",&x[i]);
			if(x[i])
			{
				kase=1;
			}
		}
		if(!kase)//全为零结束
		{
			break;
		}
		printf("%lld\n",slove(x));
	}
	return 0;
}


Softnet packets(软身网络包)是一种网络传输中的数据包,用于在软件层面对网络数据进行处理和传输。Softnet packets的概念是建立在软件定义网络(Software Defined Networking,SDN)的基础上的,即将网络功能和控制从传统的硬件设备中分离出来,通过软件来实现对网络的管理和控制。 Softnet packets的处理方式相对于传统的硬件处理方式更加灵活和可编程。它可以通过编写相应的软件程序来定义和修改网络流量的路由、转发、过滤等行为,满足不同的网络需求和应用场景。与此同时,Softnet packets还可以根据网络负载和性能的优化策略,动态地分配网络资源,提高网络的吞吐量和性能。 Softnet packets的优势在于其灵活性和可扩展性。通过软件定义的方式,网络管理人员可以更加精确地配置和管理网络流量,实现对网络的精细化控制。同时,Softnet packets的虚拟化特性也使得网络资源的使用更加高效,节约了成本和能源。此外,软件定义的网络还可以与其他技术和系统相结合,例如网络功能虚拟化(Network Function Virtualization,NFV)和云计算,实现更加智能和高效的网络管理和应用部署。 总之,Softnet packets是一种通过软件定义网络来处理和传输数据的方式,具有灵活性、可编程性和可扩展性的优势。它可以实现对网络流量的精细化控制,优化网络资源的使用,提高网络性能和吞吐量,为网络管理和应用部署带来了更大的便利和效益。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值