[POJ][1017]Packets

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

这是一道水题,但是需要特别细心才能AC

先说一下思路

对于大小为6的产品,需要一个包装

对于大小为5的产品,需要一个包装,还可以塞进去11个大小为1的产品

对于大小为4的产品,需要一个包装,可以塞进去最多5个大小为2的产品,如果不够,就塞大小为1的产品

对于大小为3的产品,每4个需要一个包装,剩下的就用来塞大小为2的产品,余1个的时候可以塞进去5个,余2个的时候可以塞进去3个,余3个的时候可以塞进去1个,剩下的用来塞大小为1的产品

对于大小为2的产品,每9个需要一个包装,剩下的全部用来塞大小为1的产品

对于大小为1的产品,每36个需要一个包装,余下的需要一个包装

上面就是思路,下面就需要细心了,有两份AC代码,一份是我写的了,纯粹照着思路写的,第二份则更加简洁

#include <iostream>
using namespace std;
int cb[4] = {9,5,3,1};
int cblock[4]={36,27,18,9};
int ablock[4]={0,7,6,5};
int main()
{
    int a,b,c,d,e,f;
    while (cin>>a>>b>>c>>d>>e>>f && a|b|c|d|e|f) {
        int sum = f+e+d;
        a -= e*11;
        if (d*5>=b) {
            a -= (d*5-b)*4;
            b = 0;
        } else {
            b -= d*5;
        }
        sum += c/4;
        c %= 4;
        if (c) {
            sum++;
            if (cb[c]>=b) {
                a -= cblock[c]-b*4;
                b=0;
            } else {
                a-=ablock[c];
                b-=cb[c];
            }
        }
        sum += b/9;
        b%=9;
        if (b) {
            sum++;
            a-=36-4*b;
        }
        if (a>0) {
            sum += a/36;
            a %= 36;
            if (a) {
                sum++;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}

然后是第二份非常简洁的代码

#include<iostream>
using namespace std;
int main()
{
	int n,a,b,c,d,e,f,t;
	int u[4]={0,5,3,1};
	while(cin>>a>>b>>c>>d>>e>>f && a|b|c|d|e|f)
	{
		n=d+e+f+(c+3)/4;
		t=5*d+u[c%4];
		if(b>t) n+=(b-t+8)/9;
		t=36*n-36*f-25*e-16*d-9*c-4*b;
		if(a>t)
			n+=(a-t+35)/36;
		cout<<n<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值