POJ 1017 Packets(简单贪心)

Packets
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%lld & %llu
Submit Status

Description
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last “null” line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

题目大意: 所有的箱子都是6*6尺寸的,但是物品有1*1,2*2,3*3,4*4,5*5以及6*6尺寸的,要求把所有的物品放进箱子中,求最少需要多少箱子。

题目思路,对于6*6,5*5以及4*4尺寸的物品每个物品需要占有一个箱子,对于3*3的物品一个箱子可以放4个,2*2的物品箱子可以放9个,1*1的可以放36个。采用面积统计1*1箱子的空位,采用向上去整的方法统计箱子。

AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int box[8];
int num[5]={0,5,3,1};
int main()
{
    while(1)
    {
        int ant=0;
        for(int i=1;i<=6;i++){
            scanf("%d",&box[i]);
            ant+=box[i];
        }
        if(ant==0) break;
        int sum=0;///所需箱子个数
        sum=box[6]+box[5]+box[4]+(box[3]+3)/4;
        int x2=box[4]*5+num[box[3]%4];  ///统计所有的大物品放进箱子中后a2物品的空位子有多少
        if(box[2]>x2) sum+=(box[2]-x2+8)/9;
        int x1=sum*36-box[6]*36-box[5]*25-box[4]*16-box[3]*9-box[2]*4;  ///求a1的空位子,只需要统计剩余的面积即可
        if(box[1]>x1) sum+=(box[1]-x1+35)/36;
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值