uva 311 Packets(贪心)

16 篇文章 0 订阅
7 篇文章 0 订阅

                                    uva 311 Packets


A factory produces products packed in square packets of the same height h and of the sizes tex2html_wrap_inline27 , tex2html_wrap_inline29 , tex2html_wrap_inline31 , tex2html_wrap_inline33 , tex2html_wrap_inline35 , tex2html_wrap_inline37 . These products are always delivered to customers in the square parcels of the same height h as the products have and of the size tex2html_wrap_inline37 . Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size tex2html_wrap_inline27 to the biggest size tex2html_wrap_inline37 . The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1


题目大意:6种行李1*1, 2*2, 3*3, 4*4, 5*5, 6*6,要将它们装在6*6的箱子中,问最少需要几个箱子。

解题思路:贪心。

①每个6*6的行李占一个箱子。
②每个5*5的行李放在一个箱子里,同时里面还能装11个1*1的行李
③每个4*4的行李放在一个箱子里,同时里面还能装5个2*2的行李,如果2*2的不够了,那么还能放1*1的行李
④每4个3*3的行李放在一个箱子里,则要视情况而定。
⑤最后如果还剩下了2*2和1*1的行李,再考虑1*1和2*2。


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
int main() {
	int a, b, c, d, e, f;
	while (scanf("%d %d %d %d %d %d", &a, &b, &c, &d, &e, &f) == 6) {
		if (a == 0 && b == 0 && c == 0 && d == 0 && e == 0 && f == 0) break;
		int ans;
		ans = f + e + d + c / 4;
		a -= 11 * e;
		b -= 5 * d;
		if (c % 4 == 1) {
			b -= 5;
			a -= 7;
			ans++;
		}
		else if (c % 4 == 2) {
			b -= 3;
			a -= 6;
			ans++;
		}
		else if (c % 4 == 3) {
			b -= 1;
			a -= 5;
			ans++;
		}

		if (b < 0) {
			a += 4 * b;
			b = 0;
		}
		if (a < 0)  a = 0;
		ans += ceil((a + 4 * b) / 36.0);
		printf("%d\n", ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值