uva 11374 Airport Express(最短路)

uva 11374 Airport Express

In a small city called Iokh, a train service, Airport-Express, takes residents to the airport more quickly than other transports. There are two types of trains in Airport-Express, the Economy-Xpress and the Commercial-Xpress. They travel at different speeds, take different routes and have different costs.

Jason is going to the airport to meet his friend. He wants to take the Commercial-Xpress which is supposed to be faster, but he doesn’t have enough money. Luckily he has a ticket for the Commercial-Xpress which can take him one station forward. If he used the ticket wisely, he might end up saving a lot of time. However, choosing the best time to use the ticket is not easy for him.

Jason now seeks your help. The routes of the two types of trains are given. Please write a program to find the best route to the destination. The program should also tell when the ticket should be used.

Input

The input consists of several test cases. Consecutive cases are separated by a blank line.

The first line of each case contains 3 integers, namely N, S and E (2 ≤ N ≤ 500, 1 ≤ S, E ≤ N), which represent the number of stations, the starting point and where the airport is located respectively.

There is an integer M (1 ≤ M ≤ 1000) representing the number of connections between the stations of the Economy-Xpress. The next M lines give the information of the routes of the Economy-Xpress. Each consists of three integers X, Y and Z (X, Y ≤ N, 1 ≤ Z ≤ 100). This means X and Y are connected and it takes Z minutes to travel between these two stations.

The next line is another integer K (1 ≤ K ≤ 1000) representing the number of connections between the stations of the Commercial-Xpress. The next K lines contain the information of the Commercial-Xpress in the same format as that of the Economy-Xpress.

All connections are bi-directional. You may assume that there is exactly one optimal route to the airport. There might be cases where you MUST use your ticket in order to reach the airport.

Output

For each case, you should first list the number of stations which Jason would visit in order. On the next line, output “Ticket Not Used” if you decided NOT to use the ticket; otherwise, state the station where Jason should get on the train of Commercial-Xpress. Finally, print the total time for the journey on the last line. Consecutive sets of output must be separated by a blank line.

Sample Input

4 1 4
4
1 2 2
1 3 3
2 4 4
3 4 5
1
2 4 3

Sample Output

1 2 4
2
5

题目大意:有两种车票,商务车票和经济车票。由于经济原因,商务车票只能买一张,经济车票可以买多张。车票都是双向的。现在问从起点到终点,的最短路径,以及商务车票在哪个站点用最划算和最后花费的总时间。
在不使用商务车票的情况下计算两次最短路,分别算出起点s到每一点的最短路ds[N], 以及终点t到每一点的最短路dt[N],并记录起点到终点的最短路Min。然后枚举商务车票(商务车票初始站点u, 终止站点v, 花费cos),使Min = min(ds[u] + dt[v] + cos, ds[v] + dt[u] + cos),并记录下使用的商务车票的u和v。维护过后的Min就是在最优的情况下使用商务车票的最短路花费,然后根据pre数组,以及记录的u和v输出路径。
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int N = 505;
const int M = 5005;
const int INF = 0x3f3f3f3f;
typedef long long ll;
int n, s, t;
int vis[N], d[2][N], en;
int head[M];
int pre[2][N];

struct node {  
    int to, dis, next;  
}edge[N * M];  

void init();

void addEdge(int u,int v,int x) {  
    edge[en].to = v;  
    edge[en].next = head[u];  
    edge[en].dis = x;  
    head[u] = en++;  

    edge[en].to = u;  
    edge[en].next = head[v];  
    edge[en].dis = x;  
    head[v] = en++;  
}  

void SPFA(int flag) {  
    queue<int> Q;  
    for(int i = 1; i <= n; i++) {  
        d[flag][i] = INF;  
        vis[i] = 0;  
        pre[flag][i] = -1;  
    }  
    d[flag][s] = 0;  
    vis[s] = 1;  
    pre[flag][s] = s;  
    Q.push(s);  
    while(!Q.empty()) {  
        int u = Q.front();  
        vis[u] = 0;  
        Q.pop();  
        for(int i = head[u]; i != -1; i = edge[i].next) {  
            int v = edge[i].to;  
            if(d[flag][u] + edge[i].dis < d[flag][v]) {  
                d[flag][v] = d[flag][u] + edge[i].dis;  
                pre[flag][v] = u;  
                if(!vis[v]) {  
                    Q.push(v);  
                    vis[v] = 1;  
                }  
            }  
        }  
    }  
} 

void input() {
    int num, a, b, c;   
    scanf("%d", &num);
    for (int i = 0; i < num; i++) {
        scanf("%d %d %d", &a, &b, &c);  
        addEdge(a, b, c);
    }
}

void print(int x) {
    if (pre[0][x] == x) {
        printf("%d", x);    
        return;
    }
    print(pre[0][x]);
    printf(" %d", x);
}

void solve() {
    int num, a, b, c;
    int Min = d[0][s], tU = -1, tV = -1;
    scanf("%d", &num);
    for (int i = 0; i < num; i++) {
        scanf("%d %d %d", &a, &b, &c);  
        if (d[0][a] + d[1][b] + c < Min) {
            Min = d[0][a] + d[1][b] + c;
            tU = a, tV = b;
        }
        if (d[0][b] + d[1][a] + c < Min) {
            Min = d[0][b] + d[1][a] + c;
            tU = b, tV = a;
        }
    }
    if (tU == -1) {
        print(s);
        puts("");   
        printf("Ticket Not Used\n");
    } else {
        print(tU);
        for (int i = tV; i != s; i = pre[1][i]) printf(" %d", i);
        printf(" %d\n", s);
        printf("%d\n", tU);
    }
    printf("%d\n", Min);
}

int main() {
    int Case = 1;
    while (scanf("%d %d %d", &n, &s ,&t) == 3) {
        memset(head, -1, sizeof(head));
        if (Case != 1) puts("");
        Case++;
        input();            
        SPFA(0);
        s = t;
        SPFA(1);
        solve();    
    }   
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值