POJ 3398 Perfect Service 树形DP 最小支配集变形

36 篇文章 0 订阅
32 篇文章 0 订阅
Perfect Service
Time Limit: 2000MS      Memory Limit: 65536K
Total Submissions: 1535     Accepted: 739

Description

A network is composed of N computers connected by N − 1 communication links such that any two computers can be communicated via a unique route. Two computers are said to be adjacent if there is a communication link between them. The neighbors of a computer is the set of computers which are adjacent to it. In order to quickly access and retrieve large amounts of information, we need to select some computers acting as servers to provide resources to their neighbors. Note that a server can serve all its neighbors. A set of servers in the network forms a perfect service if every client (non-server) is served by exactly one server. The problem is to find a minimum number of servers which forms a perfect service, and we call this number perfect service number.

We assume that N (≤ 10000) is a positive integer and these N computers are numbered from 1 to N. For example, Figure 1 illustrates a network comprised of six computers, where black nodes represent servers and white nodes represent clients. In Figure 1(a), servers 3 and 5 do not form a perfect service because client 4 is adjacent to both servers 3 and 5 and thus it is served by two servers which contradicts the assumption. Conversely, servers 3 and 4 form a perfect service as shown in Figure 1(b). This set also has the minimum cardinality. Therefore, the perfect service number of this example equals two.

Your task is to write a program to compute the perfect service number.

Input

The input consists of a number of test cases. The format of each test case is as follows: The first line contains one positive integer, N, which represents the number of computers in the network. The next N − 1 lines contain all of the communication links and one line for each link. Each line is represented by two positive integers separated by a single space. Finally, a 0 at the (N + 1)th line indicates the end of the first test case.

The next test case starts after the previous ending symbol 0. A −1 indicates the end of the whole inputs.

Output

The output contains one line for each test case. Each line contains a positive integer, which is
the perfect service number.

Sample Input

6
1 3
2 3
3 4
4 5
4 6
0
2
1 2
-1

Sample Output

2
1

Source
Kaohsiung 2006

d[u][0]=u作为服务器,u为根的子树至少有多少服务器
d[u][1]=u不是服务器,u的儿子中恰好有一台服务器,u为根的子树至少有多少服务器
d[u][2]=u不是服务器,u没有儿子是服务器(父亲是服务器) ,u为根的子树有多少服务器
显然 d[u][0]不能有儿子是d[v][1]状态 ,否则儿子v连接了2个服务器
所以:d[u][0]=∑min(d[v][0],d[v][2])
d[u][2]不能有d[v][0],d[v][2]的孩子,d[v][2]的孩子会造成v没有连接服务器
所以:d[u][2]=∑d[v][1]
d[u][1]只能连接一个服务器儿子,相当于d[u][2]去掉一个d[v][1]并加上一个d[v][0]
显然d[u][1]-d[v][0]最小的状态最优
所以:d[u][1]=d[u][2]+min(d[v][0]-d[v][1])


#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

inline void read(int&x){
    x=0;
    char t;
    while(isdigit(t=getchar()))
        x=x*10+t-'0';
}

const int N=10000+5;
const int M=2*N;
struct Edge{
    int to,next;
}edge[M];

int head[N];

inline void addEdge(int k,int u,int v){
    edge[k]={v,head[u]};
    head[u]=k;
}


int d[N][3];

void DP(int u,int father){
    d[u][0]=1;
    d[u][1]=N;
    d[u][2]=0;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int to=edge[i].to;
        if(to==father)
            continue;
        DP(to,u);
        d[u][0]+=min(d[to][0],d[to][2]);
        d[u][2]+=d[to][1];
    }
    for(int i=head[u];i!=-1;i=edge[i].next){
        int to=edge[i].to;
        if(to!=father)
            d[u][1]=min(d[u][1],d[u][2]-d[to][1]+d[to][0]);
    }
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int n,u,v;
    while(~scanf("%d",&n)){
        fill(head,head+n+1,-1);
        for(int i=0;i<n-1;++i){
            scanf("%d%d",&u,&v);
            addEdge(2*i,u,v);
            addEdge(2*i+1,v,u);
        }
        DP(1,1);
        printf("%d\n",min(d[1][1],d[1][0]));
        scanf("%d",&n);
        if(n==-1)
            break;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值