poj 3398 Perfect Service(最小支配集树形DP)

题目链接:http://poj.org/problem?id=3398
摘要由CSDN通过智能技术生成

题目链接:http://poj.org/problem?id=3398

Description

A network is composed of N computers connected by N − 1 communication links such that any two computers can be communicated via a unique route. Two computers are said to beadjacent if there is a communication link between them. The neighbors of a computer is the set of computers which are adjacent to it. In order to quickly access and retrieve large amounts of information, we need to select some computers acting as servers to provide resources to their neighbors. Note that a server can serve all its neighbors. A set of servers in the network forms aperfect service if every client (non-server) is served by exactly one server. The problem is to find a minimum number of servers which forms a perfect service, and we call this numberperfect service number.

We assume that N (≤ 10000) is a positive integer and these N computers are numbered from 1 toN. For example, Figure 1 illustrates a network comprised of six computers, where black nodes represent servers and white nodes represent clients. In Figure 1(a), servers 3 and 5 do not form a perfect service because client 4 is adjacent to both servers 3 and 5 and thus it is served by two servers which contradicts the assumption. Conversely, servers 3 and 4 form a perfect service as shown in Figure 1(b). This set also has the minimum cardinality. Therefore, the perfect service number of this example equals two.

Your task is to write a program to compute the perfect service number.

Input

The input consists of a number of test cases. The format of each test case is as follows: The first line contains one positive integer,N, which represents the number of computers in the network. The next N − 1 lines contain all of the communication links and one line for each link. Each line is represented by two positive integers separated by a single space. Finally, a 0 at the (N + 1)th line indicates the end of the first test case.

The next test case starts after the previous ending symbol 0. A −1 indicates the end of the whole inputs.

Output

The output contains one line for each test case. Each line contains a positive integer, which is
the perfect service number.

Sample Input

6
1 3
2 3
3 4
4 5
4 6
0
2
1 2
-1

Sample Output

2
1

Source


跟poj 3659很像,也是求最小支配集,不过该题有一点不同,那就是如果一个点不是服务器不能和多台电脑相连,只需修改一下模板。。

第一种状态不能与第二种状态得到,因为该子节点有一个子节点选入支配集,当前点也会被选入,此时该子节点与选入的点不相连的话,不符合题意。

所以,dp[u][0]+=min(dp[to][0],dp[to][2]);其他的不变。。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=10005;
const int inf=1<<31-1;
struct node
{
    int to,next;
}e[maxn*2];
int head[2*maxn],vis[maxn];
int dp[maxn][3];
int n,cnt;
void add(int x,int y)
{
    e[cnt].to=y;
    e[cnt].next=head[x];
    head[x]=cnt++;
}
void dfs(int u)
{
    bool flag=true;
    vis[u]=1;
    dp[u][0]=1;
    dp[u][1]=dp[u][2]=0;
    int minn=inf;
    for(int k=head[u];k!=-1;k=e[k].next)
    {
       int to=e[k].to;
       if(!vis[to])
       {
         dfs(to);
         dp[u][0]+=min(dp[to][0],dp[to][2]);
         dp[u][2]+=min(dp[to][0],dp[to][1]);
         if(dp[to][0]<=dp[to][1])
         {
             flag=false;
             dp[u][1]+=dp[to][0];
         }
         else
         {
             minn=min(minn,dp[to][0]-dp[to][1]);
             dp[u][1]+=dp[to][1];
         }
       }
    }
    if(flag)
        dp[u][1]+=minn;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)  break;
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<n;i++)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            add(a,b);
            add(b,a);
        }
        int flag;
        scanf("%d",&flag);
        dfs(1);
        printf("%d\n",min(dp[1][0],dp[1][1]));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值